Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird 78.7.1 won't download messages on startup

  • 12 replies
  • 1 has this problem
  • 33 views
  • Last reply by idahouser

more options

Well, I come here as I cannot find the answer anywhere! It may not even exist! I have TB 78.7.1 installed on my desktop and laptop. Both run Win 10 Pro. On my desktop I have 8 separate profiles, each with it's own icon pointing to a batch file for starting up TB with a specific profile. On my laptop I have 5 of those same profiles. Every profile has the server and account settings checked to check for and download new messages at startup. Every profile, except one, automatically downloads new messages when I start TB. Let's call the problem profile "XX". The XX profile will not download new messages on the desktop, but it does on the laptop. The mystifying factor is I copied the pref.js file from the laptop to the desktop. The profile opened up correctly except it did not automatically check for and download new messages. I copied the XX profile from the desktop to the laptop, and bingo, it automatically downloaded new messages! I used WinMerge to do a line by line comparison of the pref.js file from each computer. I could not find any differences that would affect the download on startup option.

Obviously, the failure to download messages upon startup is not related to the pref.js, which I believe means none of the settings available through the UI are the issue.

Where do I look now to find the cause of the problem?

Chosen solution

I marked the wrong one as the solution, and in the process lost the draft of my answer.

I got it fixed. I still have no idea what the problem was but I got rid of it! I created a new profile using a new blank folder using the same account as the problem profile. It downloaded what was on the server. The next time I opened it it automatically checked for new messages. I then changed the name of the problem profile to mark it old, and changed the name of the new profile folder to be the same as the now old problem profile. I replaced the Mail folder in the new profile folder with a copy of the Mail folder from the old problem profile. I now have a new profile using the old name with all the old emails in it which automatically checks for new messages when I start it.

So obviously, buried somewhere in the old profile folder is a problematic file that was preventing TB from checking for new messages upon startup.

Read this answer in context 👍 0

All Replies (12)

more options

I forgot to mention I use POP3, not IMAP with messages left on server.

Helpful?

more options

Have you considered other issues like your anti virus perhaps being the issue causing problem? It is far more common that about any other failure post update.

Helpful?

more options

If it was an anti-virus program issue wouldn't it affect every instance of TB, not just one out of 13 profiles on two machines? But to test it I just turned off Norton Security. Had no effect.

Helpful?

more options

If it was a Thunderbird issue why would reversing the profs.js files see the same issue on the same device. There was a issue a couple of versions ago, but the issue was in the prefs js file and you have swapped them around without an change on either device.

Have you tries safe mode? (help menu with addons disabled) That is always a good starting point.

Just as an aside. Norton's is very economical with the truth and it is not really disabled when you ask it do be. It lies. The only real way to disable Nortons is remove it. Although safe mode with networking on windows goes close for testing purposes.

Is there any error message? What is it? Is there any message in the error console (ctrl+Shift+J) that might indicate a problem getting mail?

Helpful?

more options

Matt said

If it was a Thunderbird issue why would reversing the profs.js files see the same issue on the same device.

That's what I'm trying to figure out! I did another test where I took the prefs.js file from profile XX-A, copied it to the XX profile and changed all the email references to fit XX. TB still did not check for new messages, which it does with profile XX-A.

Have you tries safe mode? (help menu with addons disabled) That is always a good starting point.

Safe mode had no impact on either of the two profiles above.

Is there any error message? What is it? Is there any message in the error console (ctrl+Shift+J) that might indicate a problem getting mail?

Here are the error messages from XX, XX-A, and XX on the laptop. The last entry in the error for XX may be the key, but I don't really know what it means other than it refers to Chrome, which I don't use. But why would a Chrome problem affect only one profile? This all makes me think that there is something in one of the other 7 files that gets changed every time TB runs that is causing the issue.

I'll post the error text in the next message.

Helpful?

more options

Maybe the (NS_ERROR_ILLEGAL_VALUE) at the end of the XX error is a key?

From profile XX Does not check for messages.

18:12:39.290 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:12:39.454 Error while loading 'jar:file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:570 18:12:39.567 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:12:39.969 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:12:40.348 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:12:40.349 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:12:41.190 Uncaught (in promise) Exception { name: "NS_ERROR_ILLEGAL_VALUE", message: "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIMessenger.msgHdrFromURI]", result: 2147942487, filename: "chrome://messenger/content/mailTabs.js", lineNumber: 419, columnNumber: 0, data: null, stack: "restoreTab@chrome://messenger/content/mailTabs.js:419:32\nrestoreTab@chrome://messenger/content/tabmail.js:1559:19\nrestoreTabs@chrome://messenger/content/tabmail.js:1580:19\natStartupRestoreTabs@chrome://messenger/content/msgMail3PaneWindow.js:1093:13\n", location: XPCWrappedNative_NoHelper } mailTabs.js:419


From profile XX-A Checks for messages.

18:14:16.175 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:14:16.361 Error while loading 'jar:file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:570 18:14:16.480 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:14:16.733 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:14:17.115 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 18:14:17.115 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19


From profile XX on laptop. Checks for messages.

[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 TypeError: singletons is null 3 ActorManagerChild.jsm:297:32 TypeError: singletons is null ActorManagerChild.jsm:297:32 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658" data: no] L10nRegistry.jsm:658:19 Error while loading 'jar:file:///C:/Program%20Files%20(x86)/Mozilla%20Thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:570

Helpful?

more options

Oops, looks like maybe the post is too long? I guess you can OK it, right?

Helpful?

more options

Another test that did not fix things. I renamed the virtualFolders.dat, panacea.dat, and xulstore.json files so that TB would recreate them. Didn't help. Of the other 4 files that get updated each time 2 are 0kb and the other 2 are identical between the two profiles.

Helpful?

more options

There are a few changes that sometimes resolve the startup issue:

https://support.mozilla.org/en-US/questions/1275606#answer-1299178

Another user fixed it by changing the Date & Time Formatting in Options/General.

Helpful?

more options

Chosen Solution

I marked the wrong one as the solution, and in the process lost the draft of my answer.

I got it fixed. I still have no idea what the problem was but I got rid of it! I created a new profile using a new blank folder using the same account as the problem profile. It downloaded what was on the server. The next time I opened it it automatically checked for new messages. I then changed the name of the problem profile to mark it old, and changed the name of the new profile folder to be the same as the now old problem profile. I replaced the Mail folder in the new profile folder with a copy of the Mail folder from the old problem profile. I now have a new profile using the old name with all the old emails in it which automatically checks for new messages when I start it.

So obviously, buried somewhere in the old profile folder is a problematic file that was preventing TB from checking for new messages upon startup.

Helpful?

more options

sfhowes said

There are a few changes that sometimes resolve the startup issue: https://support.mozilla.org/en-US/questions/1275606#answer-1299178 Another user fixed it by changing the Date & Time Formatting in Options/General.

The suggestions in the linked messages, which I think I had seen all earlier today, did not solve the problem. I just tried the Date & Time formatting change. That was a no go also.

Maybe my solution will help someone else who may have this same problem.

Helpful?

more options

The entry (NS_ERROR_ILLEGAL_VALUE) in the error file posted above must be the key. My new working profile for the same account as the old profile does not show that entry in the error log.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.