Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blocking remove / install addons.

  • 6 replies
  • 1 has this problem
  • 14 views
  • Last reply by cor-el

more options

I have question, is possible blocking option add / remove for installed addons. I have to blocking changes on my children's PC. They try modify installed addons.

All Replies (6)

more options

You can possibly achieve this by using a policies.json file via the ExtensionSettings policy. You can also use it to block access to about:config (BlockAboutConfig) and prevent Safe Mode (DisableSafeMode).

Helpful?

more options

I have added: gpedit.msc I try add options "Lock" for Kaspersky Protection. But I don't know how can I correctly create list extension...? When I tryed write "Kaspersky Protection" or "ID Extension" nothing do. Extension is not locked.

What I do wrong?

Modified by Artur

Helpful?

more options

As shown under https://github.com/mozilla/policy-templates/blob/master/README.md#extensionsettings

To obtain an extension ID, install the extension and go to about:support. You will see the ID in the Extensions section.

Helpful?

more options

I did file: "policies.json" and created folder "distribution" in: C:\Program Files\Mozilla Firefox

For KASPERSKY: policies.json has: {

 "policies": {
   "Extensions": {
     "Locked":  ["light_plugin_7571494CE0B94E11BB762B659A4AD71F@kaspersky.com"]
   }
 }

} Work correcty :-)

But someone can show me how correctly add content: {

 "policies": {
   "DNSOverHTTPS": {
     "Enabled":  true,
     "Locked": true,
   }
 }

} I can't do creat corectly file structure :-( *.json.

Helpful?

more options

The problem was resolved :-)

{

 "policies": {
   "DisablePocket": true,
   "Extensions": {
     "Locked":  ["light_plugin_7571494CE0B94E11BB762B659A4AD71F@kaspersky.com"]
   },
   "DNSOverHTTPS": {
     "Enabled":  true,
     "Locked": true
   }
 }

}

If You want block extension You need, "@mail" you can use... about:support And next You have table: Extensions, which include ID Extension "@mail".

Helpful?

more options

Hi

You forgot to remove the trailing comma in "Locked": true, A comma is only mandatory as a separator and there shouldn't be a comma before a '}'

You also need only one policies section, so you need to add the other rules under the main policies section and separate each rule with a comma.


{
 "policies": {
   "Extensions": {
     "Locked":  ["light_plugin_7571494CE0B94E11BB762B659A4AD71F@kaspersky.com"]
   },
   "DNSOverHTTPS": {
     "Enabled":  true,
     "Locked": true
   }
 }
}

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.