Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Slow connect with gmail and outlook.com

  • 10 replies
  • 1 has this problem
  • 22 views
  • Last reply by RonSH

more options

When checking or sending emails from Tbird the entire process is very slow eg Connecting to SMPT, Connecting to IMAP. I have checked my other devices in case the issue lies with my email providers and connection behaves at normal speeds. The issue therefore is within my Tbird which is at the latest release 78.7.1 (32-bit)

I would appreciate some advice. Thanks Ron

Chosen solution

In Windows Security (Defender) settings, Virus & threat protection, Virus & threat protection settings, Manage Settings, Add or remove exclusions, add an Exclusion for the TB profile folder. In TB, Help/Troubleshooting, Profile Folder, Open Folder, to open the profile folder and find its location.

Read this answer in context 👍 0

All Replies (10)

more options

What's the antivirus, and its email settings? As a first step, to test the effect on TB performance, run in Windows safe mode.

Helpful?

more options

Thanks for your input. For some reason I (as yet) cannot connect to my WiFi when in Safe Mode ... even when selecting 5 in the options list. I will have to investigate this. If there is the same 'slow' Tbird issue when in Safe Mode then what would you suggest I next check?

Helpful?

more options

With wifi, you may have to enable the network adapter manually in Device Manager.

"What's the antivirus, and its email settings?"

Helpful?

more options

My Windows 10 20H2 is equipped with the standard Windows Security ... unmodified. No changes have ever been made by me since I first installed W10 and the subsequent updates. I think that the only email app covered by Windows Security is Windows Mail? ... I can't see any Settings regards Thunderbird. However, nothing has been changed by me respective Tbird ... the only changes being updates.

Regards Safe Mode testing ... could be that my device will not permit networking. Will need to further investigate.

Helpful?

more options

Chosen Solution

In Windows Security (Defender) settings, Virus & threat protection, Virus & threat protection settings, Manage Settings, Add or remove exclusions, add an Exclusion for the TB profile folder. In TB, Help/Troubleshooting, Profile Folder, Open Folder, to open the profile folder and find its location.

Helpful?

more options

Thanks for this tip. I have made this setting. Will report after a few day of use.

Helpful?

more options

After 'adding an Exclusion for the TB profile folder' the delays experienced seem to have been resolved. As a check I have now removed this exclusion from the Windows Defender, Virus & Threat protection settings and the connection delays are still resolved.

Can't explain this ... any ideas?

Helpful?

more options

It could be the problem was not in fact caused by WD scanning the profile. But you wouldn't suffer any loss of security by keeping the exclusion in place, as the real-time background scan is unaffected. This is the general recommendation for antivirus apps and TB.

http://kb.mozillazine.org/Antivirus_software

Helpful?

more options

Thanks for all your advice. I won't close this thread yet as 'Solved' ... will give it a week or so to see if this issue reoccurs.

Helpful?

more options

Decided to keep the Exclusion for the TB profile folder. It definitely does improve the send/receive when using Windows 10 with Defender.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.