Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bank of Montreal site stopped working in Firefox

  • 6 replies
  • 5 have this problem
  • Last reply by Baz

more options

The Bank of Montreal WEB site now shows a 404 after I enter login information. The site works fine in Safari

The Bank of Montreal WEB site now shows a 404 after I enter login information. The site works fine in Safari

All Replies (6)

more options

This problem no longer exists

more options

Please mark this issue as resolved.

more options

Same problem with BMO. (85.0.2) Input Card # and Password > Click Continue > Error 404.

Emptied cache, deleted bmo cookies, Bitdefender's Trafficlight disabled, restarted FF - same issue. Tried FF in Safe Mode after repeating above actions - same result.

Other browsers - newest MS Edge and Safari (with active Trafficlight) both able to sign-on without issue.

This only recently became an issue here - though Tags above and a quickie Google seems to suggest this is a recurring issue. Looks more like a FF problem than to look elsewhere for problem. Looked at other links here all suggesting things, but nothing materially (aside from FF) has changed.

Any chance anyone has found the definitive answer to this?

more options

Issue still exists (same 'solutions' tried as above) with 86.0.

Again, no problem with site sign-on via Edge or Safari.

more options

Try these steps to see if they help.

Also, a full browser screenshot if better than that option from Firefox which only shows what's in the browser.

more options

I had visited the above link before and hit up most of the suggestions and links - tried emptying cache, deleting cookies, turning off AV programs, etc, etc - then all of that in Safe Mode, too. Nothing.

The one that I missed (well, was nervous about trying - what else could it break) was General > Network Settings > Settings and switching it from 'Use System proxy settings' to 'No Proxy'. Tried that. OK to set it.

Restarted FF and went back to BMO site, and...that seems to have fixed the issue. I was directed to the right page and was able to fully navigate that page's options.


I'm still not sure why previous settings / FF versions worked and then it didn't, but there we are. A Mystery. It also doesn't fully explain why Edge and Safari work with default.

And, just because I'm like that, I guess we'll just see how long this success lasts!