Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Sites not loading on Firefox after visiting.

  • 7 replies
  • 1 has this problem
  • 28 views
  • Last reply by FredMcD

more options

So I've been experiencing a rather annoying bug/issue, and I have a work around for it, but I would love if anyone could help me figure out the issue at hand. I couldn't find a relevant, up to date solution for this issue.

Basically, certain websites (the most notable being Reddit) will eventually no longer load. In fact, it won't even try to load. I will click a link from a Google search, or even just type in the URL for Reddit directly, and Firefox just does nothing. No error, no loading, nothing. The tab will stay blank with the URL listed as the name of the tab. I can't seem to tell if other browsers have this issue as it requires a bit of use/time to pass, but it doesn't seem to be an issue in Explorer. It isn't JUST Reddit, but it's only a couple of sites that this occurs on.

I do have a workaround --- if I tell Firefox to "Forget This Website" - suddenly it will work again. I will be logged out and see the default page due to having deleted all saved dated - but the site will work (for maybe a day) before I have to forget it again.

If this was a once a month type issue it wouldn't be a big deal, but the fact that I have to constantly re-do my local settings because of this is frustrating.

I am running Windows 10 and my Firefox version is 85.0 (64-bit). I have tried disabling any add-ons such as my AdBlocker, however that does not fix the issue.

All Replies (7)

more options
more options

FredMcD said

That is very odd. Use these links to create a new profile. Use this new profile as is. Is the problem still there? https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles Type about:profiles<enter> in the address bar.

I'm not sure I've ever even had a profile in the first place. What exactly do they do?

more options

A profile keeps all of your browser information: settings bookmarks passwords . . . . You can have more than one profile for any user. on the computer.

more options

FredMcD said

A profile keeps all of your browser information: settings bookmarks passwords . . . . You can have more than one profile for any user. on the computer.

A new profile seems to just reset all cookies - should I try just using the new profile for a while and see if the same issues occur, then?

more options

That is what I said. If the problem is gone, we can Copy parts of the old profile to the new to recover your data.

more options

FredMcD said

That is what I said. If the problem is gone, we can Copy parts of the old profile to the new to recover your data.

So, I never got around to doing this, but I DID narrow down my issue by reducing what data I cleared. I reduced it down to a single section - "Offline Website Data". If I clear that, and ONLY that, the websites in question will once again load just fine (for a while, until I have to do it again). Does that potentially help narrow the issue down?

more options

I don't know.