Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webpage URL is added to search query once page is loaded

  • 4 replies
  • 1 has this problem
  • 10 views
  • Last reply by cor-el

more options

When I open a new Mozilla Firefox window and before the homepage loads I can start to enter a search query into the unified address bar/search box.

However, once the homepage is loaded it tacks on the webpage URL onto the search query. The result looks something like this: "my search queryhttps://www.google.com". This prevents me from correctly searching what I need for once I hit enter.

It's a small nuisance, but I was wondering if there is a way to correct this? If not, perhaps there is a way to offer feadback to the Firefox team?

All Replies (4)

more options

Hi

Best is to stop loading the homepage (click the stop X or press ESC) if you intend to open a different page or use a built-in page that loads fast instead of a webpage that takes more time to load like you appear to do.

Helpful?

more options

Could you try this and see whether using modifier keys might help your workflow:

Type my search query into the address bar in an existing tab. The top line of the drop-down that says

my search query - Search with Engine

should be selected. Either:

  • Hold Shift when pressing Enter (or clicking) to launch it in a new window
  • Hold Alt when pressing Enter (or hold Ctrl when clicking) to launch it in a new tab

P.S. If you rarely interact with your home page, using a blank page is way faster and doesn't leak any information about your browsing style. That's one of the choices on the Options page, Home panel. I'm liking it.

Helpful?

more options

jscher2000 said

Could you try this and see whether using modifier keys might help your workflow: Type my search query into the address bar in an existing tab. The top line of the drop-down that says my search query - Search with Engine should be selected. Either:
  • Hold Shift when pressing Enter (or clicking) to launch it in a new window
  • Hold Alt when pressing Enter (or hold Ctrl when clicking) to launch it in a new tab
P.S. If you rarely interact with your home page, using a blank page is way faster and doesn't leak any information about your browsing style. That's one of the choices on the Options page, Home panel. I'm liking it.

Thanks for the reply.

When searching in an existing tab with a page that is already loaded, the problem does not appear. I encounter it only when I start entering a search query before a page is loaded. And the only time that can happen is when I open Firefox for the first time.

I tried using the modifier keys you suggested, however this doesn't seem to solve the problem, since what I run into is that the search query has the URL of the webpage added to it, so it gives me the wrong search results. I have no issues actually sending the search query and opening the results.

I guess I will have to disable the homepage as you and an earlier user suggested, to avoid this issue. Hopefully the problem will be resolved in future revisions of Firefox.

Helpful?

more options

You can set the startup page to an empty page. That way you can leave the homepage at its current setting.

You can modify this pref on the about:config page to set the startup page.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.