Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox ESR master password prompt twice

  • 2 replies
  • 1 has this problem
  • 46 views
  • Last reply by Mike Kaply

more options

With recent updates of Firefox ESR I'm seeing two master password prompts in FIPS mode when starting up Firefox. This article: https://support.mozilla.org/bm/questions/1262314 does not solve my particular problem. The problem I'm seeing behaves exactly how this user describes, except for me it only happens in FIPS mode.

My OS is SUSE Linux Enterprise Server in FIPS mode. My Firefox version is 78.6 ESR with no addons installed.

Disabling FIPS mode fixes the problem but I cannot do that as it goes against company policy.

I have attached two screen shots showing the double master password prompt and after entering the password, the remaining prompt still showing.

Any help is greatly appreciated.

Thanks!

Charles Robertson

Attached screenshots

Chosen solution

This appears to be this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=177175

which has been around forever.

Basically FIPS isn't well supported on Firefox.

Read this answer in context 👍 0

All Replies (2)

more options

The SUMO thread you linked above was about an issue with an expired intermediate certificate and has nothing to do with your issue. This certificate was used to verify the signatures of extensions hosted on the Add-ons website. This expired intermediate certificate caused Firefox to distrust and disable all installed extensions.

Do you have special certificates stored ?

I will move the question to Firefox for Enterprise support to see if Mike Kaply can help you.

more options

Chosen Solution

This appears to be this bug:

https://bugzilla.mozilla.org/show_bug.cgi?id=177175

which has been around forever.

Basically FIPS isn't well supported on Firefox.