Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Print Function doesn't work on a 4K SCREEN in FULLSCREEN/Maximized MODE

  • 3 replies
  • 1 has this problem
  • 7 views
  • Last reply by jscher2000

more options

I noticed when I try to click on a link to print something the printing dialogue will be kind of out of focus (hidden) so I can't do anything but press ESC to get out of it. When I scale the Firefox window to a smaller size it works as intended. On my 2560x1440 screen it works in all window sizes. Only on my 3840x2160 screen this happens when the window is maximized. Would be nice if somebody could fix this! Thank you! Firefox 84.0.2 (64-Bit) Win 10.

Chosen solution

Hi Nils, is this problem with the new print overlay launched recently, or with the system print dialog?

If there's a problem with the new overlay on hi-res displays, could you file a bug on that here:

https://bugzilla.mozilla.org/

And to get work done, here's how you toggle between the two print UIs:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch the value between true (new dialog) to false (system dialog)

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Hi Nils, is this problem with the new print overlay launched recently, or with the system print dialog?

If there's a problem with the new overlay on hi-res displays, could you file a bug on that here:

https://bugzilla.mozilla.org/

And to get work done, here's how you toggle between the two print UIs:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste tab_mo and pause while the list is filtered

(3) Double-click the print.tab_modal.enabled preference to switch the value between true (new dialog) to false (system dialog)

Helpful?

more options

Hey jescher, You are a wizard! As soon as I changed it to TRUE (NEW DIALOG) it is working now! What does this mean? Will the new dialog will become the new default one in the future?

Helpful?

more options

Yes, the new dialog is in final testing for a launch in Firefox 85 (I think, or 86). There are still many open bugs with it, so the option to switch between the two will need to remain for a while.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.