Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Other bookmarks folder is forced onto favorite toolbar

  • 4 replies
  • 1 has this problem
  • 36 views
  • Last reply by yefedef456

more options

Whenever I add something to my "other bookmarks" folder it forces itself onto the right in my favorites tool bar. This hides my two rightmost icons (besides me just not wanting it there. There is no reason for it to be there).

I have gotten around this by creating a new folder named "other bookmarks 2" and just immediately dumping everything into it if I by mistake add something to the "other bookmarks" folder.

How do I stop it from doing this? I have read people talking about changing code in Firefox etc but 1. I couldn't find out where to do that and 2. I'm not comfortable doing so (especially when this should not be an issue in the first place).

How do I fix this please?

Chosen solution

In Firefox 84, you need to toggle a pref on the about:config page to disable showing this folder on the Bookmarks Toolbar. This Other Bookmarks button on the Bookmarks Toolbar is only displayed if there are bookmarks in this folder, so another possibility is move all bookmarks in this folder to folders in the Bookmarks Menu or Bookmarks Toolbar folder.

In Firefox 85 you will be able to hide this folder via the right-click context menu on this folder or empty space on the Bookmarks Toolbar.


You can set browser.toolbars.bookmarks.2h2020 = false on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue". In the search bar at the top of the about:config page you can type "2020" to locate the pref. You can double-click the line to toggle the pref.

Read this answer in context 👍 1

All Replies (4)

more options

This link seems to talk about the exact same issue and possible solutions:

https://support.mozilla.org/en-US/questions/1311062

but it's simply too difficult for me to follow. English is not my first language and I'm not used to tinkering with code etc in browsers.

Helpful?

more options

Chosen Solution

In Firefox 84, you need to toggle a pref on the about:config page to disable showing this folder on the Bookmarks Toolbar. This Other Bookmarks button on the Bookmarks Toolbar is only displayed if there are bookmarks in this folder, so another possibility is move all bookmarks in this folder to folders in the Bookmarks Menu or Bookmarks Toolbar folder.

In Firefox 85 you will be able to hide this folder via the right-click context menu on this folder or empty space on the Bookmarks Toolbar.


You can set browser.toolbars.bookmarks.2h2020 = false on the about:config page.

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue". In the search bar at the top of the about:config page you can type "2020" to locate the pref. You can double-click the line to toggle the pref.

Helpful?

more options

OK I have tried to do this and it seemed to have worked (at least it didn't force the folder into the toolbar now). Big thank you. Idk if people behind Firefox read here(?) but suggestion would be to make it possible to remove that a bit more easily/make it an option or something.

Thank you again for the help.

Helpful?

more options

Btw I could not have done this without the second part of your message so if anyone else is looking for this information and also can't find where to make a change that's what to read first.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.