Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will not open local htm file

  • 5 replies
  • 1 has this problem
  • 16 views
  • Last reply by cor-el

more options

Firefox will not open a local .htm file that is part of the help function of an app. The path is file:///C:/Program%20Files%20(x86)/Nuance/Power%20PDF%2021/help/en_US/default.htm. I can navigate to the file and it will show up as follows:

https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2021-01-06-09-24-05-7a7d47.png

When I click on the file "Default.htm" it will not open (just shows the back-and-forth blue dots on the tab). Curiously, when I click on the file immediately below it (editing_documents_in_wordperfect.htm) it opens fine.

Why is this? It works fine on Edge.

My FF version 84.0.2 (64-bit).

Thanks.

Attached screenshots

Chosen solution

Yes, thank you. Your suggestion solves the problem. I don't think I have saved any web pages. I checked my downloads folder and it contains almost exclusively .pdf, .exe, .zip, or .jpeg files. I assume by "web pages" you mean .html files, right?

Read this answer in context 👍 0

All Replies (5)

more options

Seeing no replies in five days, I would like to renew this request. Do I need to post additional information?

Helpful?

more options

It's possible the page loads in content from another page and this is not successful due to security restrictions in Firefox.

To test whether those are creating this issue, you can temporarily turn off the following protection:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste unique and pause while the list is filtered

(3) Double-click the privacy.file_unique_origin preference to switch the value from true to false

If you reload the page, does more/different content load?

(More info on about:config: Configuration Editor for Firefox.)

The reason this restriction is exists is so if you save a bunch of downloaded web pages together in the same folder, any one page can't extract data from other saved pages. If you decide to turn off this protection, to reduce the risk of data collection attacks by scripts in pages you save to disk, please save untrusted pages in their own individual folders away from any downloaded files that may contain valuable data.

Helpful?

more options

Chosen Solution

Yes, thank you. Your suggestion solves the problem. I don't think I have saved any web pages. I checked my downloads folder and it contains almost exclusively .pdf, .exe, .zip, or .jpeg files. I assume by "web pages" you mean .html files, right?

Helpful?

more options

Yes, for example, using Ctrl+s on a page to save a local copy. Try to isolate those into their own sub-folders instead of the main Downloads folder to avoid cross-document access.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.