Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox acting weird?

  • 4 replies
  • 1 has this problem
  • 9 views
  • Last reply by FredMcD

more options

Not sure this is the right 'topic' but I just migrated all my info from my old MacBook Air to my new one, and Firefox is acting weird: I can go to various common websites, like salon and npr, but not, for example, slate.com.

Also, more importantly: 1. I can't even get to gmail. When I type 'gmail.com' in the brower, firefox does nothing. Even if I try a serach of 'gmail sign in' that will come up, but the link won't work?

2. Also, like, twitter won't work. Facebook I can get to my page but can click on anything, except if I try to message someone, it takes me to a blank page?

My Chrome browser is working, and my TOR browser as well.

Firefox is my prefered browser. What's going on? What should I do?

Thanks in advance!

John

Chosen solution

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Helpful?

more options

Fred,

Wow, yes, that solved the problem!

There was a small problem of getting out of safe mode: the firefox directions for that weren't clear, or anyways, I did it by trial and error.

But yes, seems to have worked! Thank you!

John

Helpful?

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

To get Firefox out of Safe Mode, close the browser. After, restart.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.