Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

hello

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by Scribe

more options

Hello first time poster, going to try this out and see if it works. My problem no internet why am I asking for help here, I am at wits end grabbing at straws. I am suspicious that Firefox 78.6.0esr(64-bit) Addons: Noscripts, Https everywhere and Privacy badger, is not playing nice with my Alcatel linkhub HH41.(cat4 router, turbohub, a mobile router that uses a sim card) When I log on to the linkhub web management page (http://192.168.1.1/index.html#/index) Firefox, all addons shut down, has a lock icon with a red line through it in front of the address bar. clicking on the lock reveals "You are not securely connected to this site" At this page under the address bar on the left is " ? You must logon to this network before you can access the internet" on the opposite side of the page on the right there is a radio button stating "open network login page" Clicking the radio button brings me to https://detectportal.firefox.com/success.txt but the " ? You must logon to this network before you can access the internet" remains, the only difference is in the top left hand corner of the main pane is the word success in lower case.

Spent 2.5hrs on the phone with bell yesterday, the first thing I told them was the linkhub's LAN/WAN indicator light was flashing, they didn't seem to care.

I'm almost ready to trash this thing I bought new from bell about a years ago. unless somebody has solved the same problem. I'm open to knowledgeable suggestions.

Modified by workinforalivin

All Replies (2)

more options

One more thing my OS is Debian Buster.

Helpful?

more options

Hi, I'm not a Linux user so cannot give specific advice in that regard. However, to eliminate your extensions as the cause - which is certainly a possibility, try starting Firefox in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it's OK in Safe Mode, disable any theme or extensions - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.


To remove 'You must logon to this network before you can access the internet,' type about:config into the address bar, press Enter and accept any warning, then copy and paste the following into the search box network.captive-portal-service.enabled Now on the search result, click the Toggle button at the right-hand end to change from True to False. You may need to restart Firefox to implement the change.


It might be worth disabling any antivirus programs you are using to test if that's the cause.

Can't give specific advice regarding your particular model of router, except to say that a 4G router should definitely work with Firefox and any other browser - have you tried a different browser to eliminate whether it's a Firefox issue or not? Does a different device work with the router? It sounds a bit odd that you have a flashing light...

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Modified by Scribe

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.