Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Log in With Gmail / Autohotkey Hotstrings (macro) Disabled

  • 1 reply
  • 1 has this problem
  • 6 views
  • Last reply by JMFS

more options

Hi folks,

I use Autohotkey to automatically expand things for me (auto-replace, basically). E.g., if I want it to type out my email I type, "myemail" and then it erases that and types emailname@emailprovider.com for me; if I type myadd it will type out my street address, and many many more things to make my life easier (vision impaired and by using these "hotstrings" I can ensure I don't mistype and then miss it in proofreading).

Sometime last week (I think I restarted my computer on Wednesday and there Were updates as well as Windows 10 asking me a browser-related question and I declined to change my default browser at that time) Firefox stopped allowing those hotstrings to work And I can't select, "log in with Google" (or is it Gmail? Whichever . . .) any more, either. The option is greyed out. Epic Games' launcher has that option and it tells me it will launch my web browser once I've clicked the "log in with G..." link (Firefox can't grey it out there since it's a different program) but Firefox does seem to be blocking the web page launch request.

I have tried turning off my add ons, one by one (and refreshing the page after each), to narrow it down, but none of those appear to be the culprit. I use Malwarebytes and Avira (basic, not Prime) and neither of those seem to be responsible, either. I have Windows Defender as well. My "hotstrings" are working in Chrome so I am Guessing it's to do with Firefox specifically and that bit of information might rule out MB, Avira, and Win Defender altogether. I tried a Private Window for fun and it's also blocking my macro (hotstrings).

Any ideas of other things I can try? I don't want to have to use Chrome but if I can't get this resolved I'll have to bite the bullet and use the browser that helps with my eyesight.

All Replies (1)

more options

Follow up with additional information - Firefox isn't opening Any external links. E.g., when I click on a link within Thunderbird Firefox won't open it. It has to be some silly setting I'm missing. I'll keep poking around while keeping my fingers crossed someone else has an "aha!" moment to let me know how blind I'm being.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.