Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

With the latest version 84/Win 7 magnet handling has changed

  • 5 replies
  • 1 has this problem
  • 17 views
  • Last reply by j.kay

more options

I can't open a magnet link without a pop up asking to allow, this wasn't the case with earlier versions. Quite annoying.

Chosen solution

I always used Private mode.

That said I think I figured it out. In Privacy & Security I changed 'never remember history' to 'use custom settings for history' and checked 'always use private browsing mode.' Seems to be working as it did.

Thanks for all your effort. Happy New Year.

Read this answer in context 👍 0

All Replies (5)

more options

Can you send a screenshot using snip and not the one in Firefox showing the popup?

Helpful?

more options

I should further explain that I am running in Private Browsing mode. The 'always allow' only works till I restart FF. This pop up never appeared before.

Helpful?

more options

When not in Private Browsing mode it works as it should. Why this change? Everything was fine before.

Helpful?

more options

If it works in private mode, I wonder if it also works in safe mode? if it does then it looks like an add-on maybe the problem which is why I wanted a full screenshot of your browser to see what add-ons are installed. see my screenshot

Helpful?

more options

Chosen Solution

I always used Private mode.

That said I think I figured it out. In Privacy & Security I changed 'never remember history' to 'use custom settings for history' and checked 'always use private browsing mode.' Seems to be working as it did.

Thanks for all your effort. Happy New Year.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.