Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

no videos working on latest update

  • 4 replies
  • 2 have this problem
  • 28 views
  • Last reply by 22gi

more options

Now videos working in latest version of Firefox. I disabled all add-ons and still no videos working.

All Replies (4)

more options

Could you describe the situation in more detail. Do the player rectangles display an error message, or a loading animation, or are they blank? If the video seems to be loading, are the controls not working?

Helpful?

more options

For example,YT videos has a spinning circle and then says if video fails to load try restarting your device. I've already done that and disabled hardware acceleration and all add-ons and still no video. All other sites have spinner showing loading but nothing. Yes I do see controls and on YT if I hover over timeline I see different stages of the video or thumbnails that should be playing.

Helpful?

more options

jscher2000 said

Could you describe the situation in more detail. Do the player rectangles display an error message, or a loading animation, or are they blank? If the video seems to be loading, are the controls not working?

For example,YT videos has a spinning circle and then says if video fails to load try restarting your device. I've already done that and disabled hardware acceleration and all add-ons and still no video. All other sites have spinner showing loading but nothing. Yes I do see controls and on YT if I hover over timeline I see different stages of the video or thumbnails that should be playing.

Helpful?

more options

I also can't play Video on some machines with Beta 85. It cannot be played even with the new profile, but it can be played by returning to Firefox 84. Machine with problems in my case Core i9 9900k + RTX 2080 Core i3 4130 Machine with no problem in my case Celeron N4120 The OS of all machines is Windows 10 64bit.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.