Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not loading Yahoo

  • 7 replies
  • 1 has this problem
  • 7 views
  • Last reply by cor-el

more options

I cant seem to get yahoo page to open on home page or any tab. It just spins and does not load. I can go to any other website it works fine.

I have uninstalled Firefox, Re-imaged my laptop and of course cleared the cache. It does work on google chrome, Edge and IE. updated OS, java, flash player

What more needs to be done.

HP EliteBook 755 G3 Notebook PC Windows 10 Pro 64 Bit 16gb ram Processor AMD PRO A12-8800B R7, 12 Compute Cores 4C+8G, 2100 Mhz, 2 Core(s), 4 Logical Processor(s) OS Version 1909 Firefox 83.0 64 Bit

I cant seem to get yahoo page to open on home page or any tab. It just spins and does not load. I can go to any other website it works fine. I have uninstalled Firefox, Re-imaged my laptop and of course cleared the cache. It does work on google chrome, Edge and IE. updated OS, java, flash player What more needs to be done. HP EliteBook 755 G3 Notebook PC Windows 10 Pro 64 Bit 16gb ram Processor AMD PRO A12-8800B R7, 12 Compute Cores 4C+8G, 2100 Mhz, 2 Core(s), 4 Logical Processor(s) OS Version 1909 Firefox 83.0 64 Bit

All Replies (7)

more options

Have you tried in safe mode and what are you cookies set to?

more options

Its all set to default. Yes I tried safe mode same problem. No add ons no extensions

Modified by buzzme

more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

What is your default? Here is a screenshot of my default.

more options

Mine is the same all at default. NO ADD ONS NO EXTENTIONS

Modified by buzzme

more options

Is there anything showing in this section blocked?

more options

What security software do you have?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.