Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Clearing cache is not clearing cached style sheet - soooo frustrating!

  • 1 reply
  • 1 has this problem
  • 8 views
  • Last reply by cor-el

more options

I have been building websites using Firefox for a good 10 years now, but over the last year or so clearing the cache has become more and more frustrating and it's making Firefox unusable for developing websites.

Basically, I am making edits to a website's style sheet and uploading it and the new style sheet is not then being loaded in Firefox.

I have spent the last hour+ looking for a definitive answer to this problem.

I am using both methods I know for clearing cache

1) click on the burger and go to Privacy and Security / go to cookies and site data / click clear data / leave "cached web content" clicked on (switch off "Cookies and Site data") / click clear

2) hold command / shift / R

Most of the time it seems both these methods don't seem to work as the browser won't load the new style sheet.

I know the style sheet has uploaded as when I test the site in Safari (I might have to use the Empty Caches function once) and the new style sheet loads straight away.

I don't know what I'm doing wrong, or may be I am missing something fundamental that will cure this problem - all I can say is, it is very, very, very annoying - and really wastes time when you're trying to work.

Is anyone else getting these problems and is there a quick and easy way to be ensuring the cached css file does not keep loading.

btw I also used a private window and was still getting the same problem.

I like using Firefox and don't really want to use another browser as they are rubbish in other ways, but feel like I'm getting to a point where I have no option if I don't find out how to solve this problem.

Any help will be greatly appreciated.

Regards

D

All Replies (1)

more options

You can possibly disable the HTTP cache while the devtools are open via the devtools settings.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.