Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Startup lag

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by JohnPhnow

more options

For the past couple of month Firefox lags at startup. It takes the program around 15 seconds from the moment I click the icon until it's ready to do anything (with a blank window as seen in the screenshot). I've tried refreshing Firefox but it didn't help. When I tried opening it safe mode it still takes more or less the same time to start (except without the blank window). After that I tried deleting my add-ons (which aren't many, adblock and fb container) but it have any effect. I'm running it on a laptop with I7-8750H processor and 16 gigs of ram so resources shouldn't be a problem (cpu at no more than 50% at program startup). Please advise.

Attached screenshots

All Replies (2)

more options

This might be because of the extensions added or due to themes which increases the startup time . Note that not all extensions and themes cause the problem try running the safe mode if the problem still persist then provide some more information

Helpful?

more options

Like I've written, I have already checked the browser without any add-ons and extensions. Running safe mode doesn't help much since it takes the program to start safe mode almost the same time as the startup lag. What information do you need?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.