Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Incoming HTML messages don't wrap correctly since new 78 update

  • 8 replies
  • 1 has this problem
  • 54 views
  • Last reply by firezombie

more options

As the title says, the text wrapping is not working correctly in incoming HTML messages. This results in having to scroll horizontally with almost all HTML formatted messages, before the update maybe 1/10 messages required horizontal scrolling.

I use the vertical view and plain text word wrapping works as expected.

Thanks

All Replies (8)

more options

am I the only one with this problem?

Helpful?

more options

There have always been issues with HTML from some apple products and Linux distributions that respectively use Linux specific HTML and apple specific HTML. Something about the way line breaks are defined.

Then there are those that send mail wrapped in a table, tables do not wrap. This becomes particularly problematic when the sender uses a very large high resolution monitor and yours is a smaller lower resolution, so the table that wrapped just where they demanded it to on their system works not well at all on someone elses. This is often seen with outlook users.

Try pressing the forward or reply button and looking at the emails in the compose window. tables show up there are a red border around blocks of text.

Helpful?

more options

Thanks Matt for the suggestion. I have tried to verify several email to see if there are those tables you mention and indeed I see that word wrapping has problems in those cases. But does this apply also when tables are only on a part of the message?

I think there's something else going on. When reading the message in the message pane word wrapping doesn't function properly, but in the compose windows it does, for example with a message with this problem when I reply in HTML format the text is adaptive in the compose window.

I don't understand why these different behaviors in reading and writing windows.

And also the word wrapping problem is also for messages that DON'T have any tables. It does't seem it's about break lines because it's not the end of a sentence but rather half words that go outside the boundary of the message pane.

As I said I only started having this problem recently, and I think since the 78 update but I am not 100% sure.

Helpful?

more options

I have an idea what it might be but need confirmation. When you select an email to read, it will show in Message Pane. You will see a header section that displays the 'FROm, TO, Subject Date info. Just above that info will be the buttons, Reply, Forward, Archive etc and the last one is 'More'.

Are all of those buttons clearly visible? If not please make that area wider or make window wider so all buttons are now clearly visible.

When all buttons are clearly visible, do you now see the content properly even if you need to use the veritical/horizontal scrollbars ?

If I set to use 'Vertical' view or indeed any View does the same and then force the Message area to be a bit too narrow, some of the default buttons disappear and at the same time I lose the Vertical scroll bar (if enabled). The horizontal scroll no longer scrolls fully to the right and text is cut off. This is a known bug and it has been reported. In the past, it was possible to Customise those particular buttons, so they only displayed an icon. This meant you could narrow the area and still see all the buttons and it also meant you could see all the text.

Please check this for me.

If what I describe is your issue then there is an addon which allows you to do some customising on buttons to show icon only and it should help the situation. https://addons.thunderbird.net/en-GB/thunderbird/addon/msghdr-toolbar-customize/

Helpful?

more options

you are right think this is the problem, unless I make the message pain super wide and I can see all the buttons text wrapping does not work properly and I also lose the horizontal scrolling bar. So this is a known bug?

Helpful?

more options

It is known because I reported it. https://bugzilla.mozilla.org/show_bug.cgi?id=1670934

If the customise message pane toolbar was available, I would have advised you to customise the message pane header toolbar to use only icons, so they use less width. But now you would need to use that addon to get only icons.

Somehow, the width of that toolbar adversely effects what is displayed in the reduced width content area of Message Pane.

Helpful?

more options

I also have this problem, which is new since the installation of v78. Previously the text automatically fit into the viewing area, and now it expands beyond the viewing margins, slowing down viewing. I also have a problem with being unable to drag emails or folders with the mouse since this last update to v78.

Helpful?

more options

Latest update and this problem is back again. It was solved using the suggestion given by Toad but now it seems that the solution is not compatible with the Compact Headers add-on. So does anybody know what's the latest trick to solve this issue? Thanks!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.