Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Email links issues

  • 9 replies
  • 1 has this problem
  • Last reply by cor-el

more options
For about a month now I have been having issues opening email links with Firefox. Not all email links just ones from Betty Crocker, Pillsbury and Life Made Delicious. The links are not resolving properly. This is what comes up. It should resolve to. I can get around this by copying the first link to Edge and it will resolve the link and then copy and paste back into Firefox. I would rather not have to do this for each link I might want to look at. I have uninstalled and reinstalled Firefox. This has not helped.

All Replies (9)

more options

You said it in the beginning... it's not resolving properly. I got the same thing on both links. You may want to try clearing your dns cache or even change it another provider to see if that helps. I use cloudflare /, but you should do your research to see which dns provider is closes to your location.

more options

Thank you for your reply. I have now tried both of your suggestions. Unfortunately neither helped.

more options

I had no problem with the Betty Crocker link. Are you opening the link from within the browser, or another program?

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

I am opening the link(s) from my Outlook email. I have no issues opening any other links from emails. Just the 3 I mentioned in my question. They all come from General Mills as the parent company. They have not changed anything in the links so far as I can tell. I checked older emails from them to see. Old email links work fine and resolve okay in firefox. I have tried copy and paste of the link into Firefox. If how they are doing the links has changed I would think pasting the links in that dreadful Edge would not work either. I did as request and started Firefox in safe Mode. This did not help. This is not the end of the world kind of thing but it sure is annoying. I really do appreciate the suggestions.

more options

Would you be willing to send me a copy of one of the troubling emails? I am sending you a Private Message.

more options

Yes, I would be willing to send one of the emails.

more options
more options

I see you are using as your e-mail provider. Ask their support about tthis.

more options

Works fine here.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window