Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Turn OFF Thunderbird UpDate nag? 78.3.2 (32bit)

more options

There is NO setting to turn OFF AutoUpdates *OR* the Nag that one is available. I do NOT want updates!!

      • New versions ALWAYS break something and I have to spend hours attempting to fix them!

In fact, I wish I could GO BACK to ver 45! Thanks, Keith

All Replies (10)

more options

Version 45 was nice in many respects but would you really want to use something that has had a lot of security updates since.

I suggest you try the following to see if it works for you. See image below as guide.

Exit Thunderbird.

  • Type 'Run' in search and select 'Run' app
  • In 'Run' app type regedit and click on Ok
  • Locate HKEY_LOCAL_MACHINE\Software\Policies
  • Right click on 'Policies' - select 'New ' > 'Key' - name it 'Mozilla'
  • so you have : HKEY_LOCAL_MACHINE\Software\Policies\Mozilla
  • right click on 'Mozilla' - select 'New ' > 'Key' - name it 'Thunderbird'
  • Now you have: HKEY_LOCAL_MACHINE\Software\Policies\Mozilla\Thunderbird
  • Right click on 'Thunderbird' select 'New' > 'DWORD 32 bit'
  • On the right, will appear 'new Value' -REG_DWORD - right click on 'new value' and select 'Rename' and rename as 'DisableAppUpdate'.

Note: Even if you are running 64-bit Windows you must still create a 32-bit DWORD value.

  • Double click on 'DisableAppUpdate' and Set its value to 1. Then click on OK.

Start Thunderbird

Menu icon > Options > Options > Advanced > 'Updates' tab Thunderbird updates It will state current version number. Options are removed and replaced by: 'Updates disabled by your system administrator'

To undo the change, remove the DisableAppUpdate 32-bit DWORD value you have created, then restart Thunderbird.

Modified by Toad-Hall

Helpful?

more options

Thanks Toad-Hall! I might get around to doing that. Could you just have them add this back in as a checkbox in the next version please? They keep removing things, making things worse, and requiring all these convoluted work-arounds to fix. Like the Inbox not being COMPACT, that was a deal-breaker until I found the work-around. Also the SEARCH sucks now! I used to hit ENTER to do a global search when nothing was found in the current folder, NICE! (now you have to do all kinds of looking and clicking to do a global search!). Thanks, Keith

Helpful?

more options

re :Could you just have them add this back in as a checkbox in the next version please?

It might sound simple but it is not. The response was this "We (Thunderbird) use the Mozilla update service. Mozilla removed the "never check" function and showing a not working option is senseless." The entire functionality got removed and is not going to be replaced. I did discuss it with developers. Please note that Thunderbird is independent of Mozilla, but Thunderbird is dependent on certain services from Mozilla. If Mozilla make certain changes then Thunderbird just has to go along with the flow. When changes occur in Mozilla, there are occasions when Thunderbird has no option. This has been an pain on various occasions where it seems impossible to get through to the developers that what works for Firefox does not necessarilly work for Thunderbird. It does not effect everything, but in this instance, it did.

Helpful?

more options

re :Also the SEARCH sucks now! I used to hit ENTER to do a global search when nothing was found in the current folder, NICE! (now you have to do all kinds of looking and clicking to do a global search!).

Yep i found that bug a couple of months back and reported it. Apparently is has been 'assigned' but no word of when it can be fixed as yet. See info: https://bugzilla.mozilla.org/show_bug.cgi?id=1663153

Helpful?

more options

Thanks Toad-Hall; Isn't the whole point (philosophy) of Mozilla to NOT be like Microsoft! (forcing unwanted things). This is why I want to go back to TB45 and then NEVER do an update, EVER! (the security risk is worth it). But I do appreciate this forum, which would never happen at MS! ( I have FireFox on one computer, and I CRINGE as the Update popup is nagging me and I wonder what it will break). Thanks, Keith

Helpful?

more options

Have you tried the information I provided ?

Helpful?

more options

you may also check this page to disable thunderbird auto-update, (please upvote the Q+A in that page if its helpful).

Helpful?

more options

Update on the search issue.... Developers have been working on the problem and have come up with a fix. It has been put forward for checking and testing, literally within the hour, so this is hot off the press. So, it should reappear in Thunderbird soon, just not sure which update at the moment.

The information I gave about policies and setting something to stop all updates, - as that was what you specifically requested - would need to be removed if you want to check for updates but do not install until you say ok. I know you did say you did not even want to be told that one is available, but for anyone else reading this who does want to know.......

Version 78 has a new location for the setting. Menu app icon > Options (Preferences in a MAC) Select 'General' Scroll down to 'Updates' section select 'check for updates, but let me choose whether to install them' uncheck - do not select - 'Use a background service to install updates'

Please note: the Options/Preferences now has a search box in top right corner, so if you do not like scrolling then type 'update' in the search and the view will specifically only show anything to do with updates.

Helpful?

more options

Thanks, I will watch for release notes...

Do you know if they fixed the "Compact" inbox they broke recently? IE recent update made the Inbox etc all spread out double-spaced. Had to go thru convolutions to repair it, it was a deal breaker, another reason to go back to 45. (I am still at 78.3.2, too scared to update). Thanks, Keith

Helpful?

more options

Is this the "Compact" issue? 78.4.3 notes say it is still an unresolved bug;

UNRESOLVED Message list is not focused at startup

Waiting for that fix before updating... Thanks,

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.