Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Clearing cache also clears all logins!

  • 18 replies
  • 1 has this problem
  • 33 views
  • Last reply by cor-el

more options

Hi All,

Several times I've cleared my cache and managed to also delete ALL of my logins. I most certainly do uncheck the box for "Cookies and Site Data", leaving only "Cached Web Content" checked and it still deletes all info. Also whenever I go back in that page, both are (again) checked.

What am I doing wrong?

Is there a way in "about:config" to default this area to "Cached Web Content" only?

Russ

All Replies (18)

more options

Are you talking about your being logged into websites, or the Password Manager?


Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out.


You may be in Private Browsing mode or told Firefox not to remember.

Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings.

Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

Helpful?

more options

You should keep the cookies if you only clear "Cached Web Content".

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

There are extensions that can clear the cache.

Helpful?

more options

FredMcD said

Are you talking about your being logged into websites, or the Password Manager? Your ‘logged-in’ status is stored in special cookies. If the cookie is removed, you are logged out. You may be in Private Browsing mode or told Firefox not to remember. Type about:preferences#privacy<enter> in the address bar. The button next to History, select Use Custom Settings. Turn off Always Use Private Browsing Mode Turn on Remember My Browsing And Download History At the bottom of the page, turn on Clear History When Firefox Closes. At the far right, press the Settings button. Turn on ONLY Cache and Form And Search History leaving the others off.

I'll give this a try and report back, thanks!

cor-el said

You should keep the cookies if you only clear "Cached Web Content".
  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear...

This is what I have been doing, it still removes all my login info. Doesn't sound like "the plan", but it is the result.

Russ

Helpful?

more options

Do you mean that if you only tick "Cached Web Content" you no longer have cookies present if you click "Clear Data" another time and under "Manage Data" ?


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

more options

cor-el said

Do you mean that if you only tick "Cached Web Content" you no longer have cookies present if you click "Clear Data" another time and under "Manage Data" ?

This is what's happening, see pic. When I toggle off the "cookies and site data" box then select the clear button, it still deletes these items. Also, the default appears to be that both these boxes are checked each time the options page is displayed. Is there a way to make the box for "cookies and site data" remain unchecked as the default?

Russ

Helpful?

more options

Both are always checked each time you open this dialog and AFAIK there is no way to modify this behavior.

You only posted one screenshot and not a second screenshot that shows what is left if you click the Clear button and then reopen the dialog to see the result, so we can confirm that cookies were removed.

Note that Firefox uses the caches for internal purposes, so it is possible that new items appear in the the disk cache overtime.

Helpful?

more options

I dunno, I'm old and maybe got confused on what box was checked, seems to have worked this time. Here's a before and after shot, after clearly showing cookies at 6mB & cache at zero. I went back and checked the sites that needed a login and they're intact now. All I can do is admit I'm a dumb___ for now...

Russ

PS- I sure miss the older, much simpler (pre 56.0) version!

Modified by RASelkirk

Helpful?

more options

The second screenshot shows that you still have the cookies after you cleared the cache, so this works as expected and nothing to worry.

Helpful?

more options

Well, not so fast! Woke up this morning and every site I've gone to requires me to log in again. So, overnight something magically cleared all my logons with no user interaction. Is this POS on some kind of timer? It's becoming quite aggravating! Not sure what's worse, the constant need to log on or the not knowing WTF is happening here...

Russ

Helpful?

more options

Profile data can be removed or not recorded in several ways;

  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (In the address bar,type about:preferences#privacy<enter>)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers
    Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.

Helpful?

more options

FredMcD said

Profile data can be removed or not recorded in several ways;
  • 1) Running Firefox in Private Mode (nothing is recorded)
  • 2) Privacy settings; (In the address bar,type about:preferences#privacy<enter>)
  • 3) Many disk cleaners and anti-virus type programs can remove data from browsers
    Open their settings and have them leave the browsers alone.
  • 4) Mal-ware.

Well I don't do #1, #2 was addressed several x's in this post, I checked my Malware-Bytes settings on #3 and see it's "protected" whatever that means which leaves #4. I'm pretty sure there's no malware as the Mw-B pro uses several realtime protections, I keep "Process Explorer" (super-duty Task Manager) running all the time and monitor at it frequently. Why did this happen overnight?

Do the settings in this "about"config" pic look normal?

Russ

Helpful?

more options

I posted this to the Mw-B forum and got an almost instant reply. The person linked to this article: https://www.wilderssecurity.com/threads/getting-logged-out.433525/#post-2959139. So I have changed "privacy.purge_trackers.enabled" to true and will see what happens...

Russ

Helpful?

more options

RASelkirk said

I posted this to the Mw-B forum and got an almost instant reply. The person linked to this article: https://www.wilderssecurity.com/threads/getting-logged-out.433525/#post-2959139. So I have changed "privacy.purge_trackers.enabled" to true and will see what happens...

Firefox recently enabled first-party tracker protection for sites you have not visited during the past 30 days. If you have Firefox set to clear browsing history when it closes, then Firefox will always want to purge all your cookies at the next cookie check. So yes, these two features are not compatible and you need to turn off the new one as you've described.

(We actually have a lot of threads on this, but the way this one developed, it didn't seem to be about scheduled cookie clearing.)

Helpful?

more options

Note that you need to set privacy.purge_trackers.enabled = false to disable this feature.

Quote: So I have changed "privacy.purge_trackers.enabled" to true and will see what happens...

Helpful?

more options

I'm soooo confused now. All logins were intact this morning so I'll wait & see what the "wrong" toggle does for awhile. I'll prolly end up just using my portable v56 for everything except the banking sites which require newer versions.

Too bad FF has become like Microsoft or our federal gov't - waaaaay too bloated and overly complicated!

Russ

Helpful?

more options

privacy.purge_trackers.enabled = true can work, but only if you keep the history and aren't using "Clear history when Firefox closes" to clear the browsing history. The purge trackers feature uses existing history to determine if you have visited specific websites recently and if there is no history present for a domain then involved cookies are removed, so if you now are recognized on the next day then this means that Firefox found history and that you keep these cookies.

Helpful?

more options

Something else odd that happens since upgrading to v80+. Whenever cookies/cache are cleared, Amazon locks me out of my account. On trying to sign in, I get shunted to a page that asks me to respond to a text message sent to my phone of record. That number is correct but I never get a text, so I end up calling them on the phone and jumping thru numerous hoops to get back in. They are clueless as to why this is happening but suggested I remove the phone number so any contact will be forced to happen by email. Will see next time I'm locked out - pretty sure it will happen again since it's been 2x's in the past day and 3x's in a month.

Russ

Helpful?

more options

Just make sure you keep these cookies. I don't know whether cookies with an allow exception are affected as well by the purge cookie feature or that currently only history visits matter.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.