Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Non alphabetic characters(i.e. Korean, Chinese, Japanese Hebrew etc.) are not shown properly

  • 6 replies
  • 1 has this problem
  • 14 views
  • Last reply by cor-el

more options

I'm having problem with displaying non alphabetic characters. Could anyone please tell me why it's happening and how to fix it?

Thanks in advance!

Attached screenshots

All Replies (6)

more options

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1


Also see: https://support.mozilla.org/en-US/search/advanced?q=fonts&language=en-US&product=firefox&sortby_documents=relevance&a=1&w=1

Helpful?

more options

Do you have a font installed that covers this CJK Unicode range ?

You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range.

See also:

Helpful?

more options

cor-el said

Do you have a font installed that covers this CJK Unicode range ? You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range. See also:

well, it happened all of sudden and it shows properly 70% of the time and it doesn't 30% of the time. So I don't think it's the problem with the CJK unicode font. But thanks for the suggestion.

Helpful?

more options

FredMcD said

Type about:preferences#general<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own. Fonts Information - Detected via Flash http://browserspy.dk/fonts-flash.php?detail=1 Also see: https://support.mozilla.org/en-US/search/advanced?q=fonts&language=en-US&product=firefox&sortby_documents=relevance&a=1&w=1

It's been already turned on but it's the same. The thing is it happens only sometimes and it started to happen all of sudden.

Helpful?

more options

cor-el said

Do you have a font installed that covers this CJK Unicode range ? You may see little boxes with the hex code of the character if you do not have a font installed that covers this Unicode range. See also:


How should I install the right font then? I don't think it's the font problem though since these boxes show up only sometimes and I just don't know when it happens and when doesn't.

Helpful?

more options

What font is specified and what font is Firefox trying to use (if any) ?

You can right-click and select "Inspect Element" to open the builtin Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Font tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.