Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bing search engine not properly working.

  • 3 replies
  • 2 have this problem
  • 38 views
  • Last reply by kluu

more options

I have used Bing with no problems for years now, recently it has been giving a banner at the top whenever I use it stating that a website is slowing the browser, then options stop or wait. I have never had this before. It comes up on every page that is opened in Bing. I have waited and never seen a web page open or anything. Also, none of the functions on the Bing page are working. I cannot click the three bar link for more options, change the safe search option, or sign in to my Microsoft account. All these links are dead. When on a page I cannot use the filter link. I also cannot click on anything at all while the banner notice is up. I have tried to get help form Microsoft and they were unable to do anything. They suggested using their browser Edge. They suggested emptying the cache, which I did with no change, and they suggested uninstalling Firefox and reinstalling it. I do not want to do this because it will destroy al my formatting and lose lots of links, etc... as it has every other time I have done this. I hope someone here will be able to help me. I prefer Bing search engine to all the others. I have tried Google and DuckDuckGo and they do not work for me, or find what I am searching for as well as Bing has. The others seem to be more for purchasing and not searching and so I do not like or trust them. Using Windows 10 on a Desk top PC, and had no trouble with Bing until the last week or so.

Modified by kluu

All Replies (3)

more options

Please let me know if there is anything you need to help me with this.

Modified by kluu

Helpful?

more options

Are you using the built-in Bing search feature? When I search for Firefox, the URL has certain codes like this:

https://www.bing.com/search?form=MOZLBR&pc=MOZI&q=firefox

That page is very simple and loads fast, so that's why I'm wondering if you are using something more customized. Does your results URL look like that?

Note: there's a moderation feature that delays posts with URLs, so if you share a URL without putting a space before the .com, you won't see it right away.


Could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Helpful?

more options

I have not modified the search to my knowledge and am using the Firefox built in Bing. Search for Firefox had the same address as you provided.

When I opened Firefox in safe mode I searched for Bing home page and when used, it was fine. This mean there is some extension that is messing this up, Right?

I disabled each extention in turn and after disabling AdBlock Bing worked fine. I then went into AdBlock and made Bing site an exception to AdBlock and things are working fine again. In changing over from Bing to Microsoft Bing they must have added something AdBlock does not like.

Thank you for leading to this solution.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.