Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Everytime I open Firefox all my Add-ons get disabled. I tried other solutions, but they didn't work

  • 7 replies
  • 1 has this problem
  • 34 views
  • Last reply by Leo

more options

I tried other solutions, but they didn't work. The Image of the Add-on turns grey like the bar at the top and doesn't work anymore. I have to manually restart it if I want it to work...

All Replies (7)

more options

You did not say what you tried so . . . .

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Disable all add-ons. Then restart. Is the problem still there?

Helpful?

more options

FredMcD said

You did not say what you tried so . . . . Start Firefox in Safe Mode {web link} A small dialog should appear. Click Start In Safe Mode (not Refresh). Disable all add-ons. Then restart. Is the problem still there?

Problem still here

Helpful?

more options

Do the extensions show as disabled on the about:addons page or are merely the extensions not working ?

Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) because not all extensions may work in PB mode ?

Helpful?

more options

cor-el said

Do the extensions show as disabled on the about:addons page or are merely the extensions not working ? Are you possibly using permanent Private Browsing mode (Always use Private Browsing mode; Never Remember History) because not all extensions may work in PB mode ?

They are just not working and their symbol is not showing. I am not in PB mode

Helpful?

more options

Do you see messages about extensions in the Browser Console when you start Firefox ?

Helpful?

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Helpful?

more options

FredMcD said

It’s possible that there is a problem with the file(s) that store the extensions registry. Type about:support in the address bar and press enter. Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox. Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory. Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry. New files will be created when required. After, restart Firefox. See "Corrupt extension files": +++++++++++++++++++++++++++ You will have to approve the updating one last time.

What do you mean with "Corrupt extension files" and where can I find it?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.