Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hotmail email speed

  • 4 replies
  • 1 has this problem
  • 47 views
  • Last reply by cor-el

more options

My Hotmail is no longer opening at the original speed on Firefox. Can anyone suggest a reason why?

All Replies (4)

more options

Hi juliojr523, do you have any other tabs or apps open at the same time as opening your Hotmail? If so, that might be slowing down the speed of your browser. Another issue may be that your network speed is slow. Do you use wireless internet? If you are far away from your router/internet box, it may simply cause your network speed to be slower. Another suggestion is that you might have a simply slow computer. Depending on what OS you use, Hotmail may have recently updated it's site/app, and that may cause you to have issues if you have an older computer/laptop. Let me know if any of my suggestions were true/helped!

Helpful?

more options

Hi Sawyer, thanks for the quick response. Yes, the one thing that you mentioned is, I may have too many open tabs. Thing is, this never happened before I recently reinstalled windows 10. The other thing is, my hotmail is the only tab that is slow in downloading. If I open it on Microsoft Edge it's super fast. Interesting right?

Helpful?

more options

Yes, that is interesting. Hm... I'm not sure on why that's not working then, if it works fine in Microsoft Edge and it's the only tab not working well. I wish I could be of more help though.

Sawyer

Helpful?

more options

Do you have content blocking extensions installed ?


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.