Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

configuration to email

  • 5 replies
  • 1 has this problem
  • 9 views
  • Last reply by lesley

more options

I have Firefox version 80.0 installed and Thunderbird version 68 email app to view my email. All was working fine.---I click on Moz T-Bird logo on my Dell Windows 7 desktop computer and a screen appears showing all mail and folders, but now I cannot receive nor send any email. If I click on INBOX, I get a blue revolving circle that continues indefinitely without a message. If I click on SEND message, I receive a message which states: Peer using unsupported version of security protocol. The configuration related to mail.brainstorminternet.net must be corrected. I can log in to my ISP provider website which provides a web-based email interface and then log-in to view my mail. I called the company and checked to see if the IMAP was correct. It was. Hopefully you can offer some suggestions as to resolving this problem.

Firefox Desktop -> Thunderbird

Modified by Andrew

Chosen solution

re :Thunderbird version 68

Are you sure it has not updated to version 78* ? There were changes in version 78* regarding the minimum TLS that could be used.

If your server does not support tlsv1.2 then the following will fix: In Menu app icon > Options > General Scroll forever to the bottom and click on 'Config Editor' accept the risk In search type: tls.version look for this line : security.tls.version.min Double click on line to open an edit window and enter the number 1 click on OK. Exit window - top right x

Some people found that they could use security.tls.version.min set to 3, BUT to make sending of emails work they had to change this setting: security.tls.version.enable-deprecated, set value to 'True'.

Finally, Restart Thunderbird.

Read this answer in context 👍 0

All Replies (5)

more options

Chosen Solution

re :Thunderbird version 68

Are you sure it has not updated to version 78* ? There were changes in version 78* regarding the minimum TLS that could be used.

If your server does not support tlsv1.2 then the following will fix: In Menu app icon > Options > General Scroll forever to the bottom and click on 'Config Editor' accept the risk In search type: tls.version look for this line : security.tls.version.min Double click on line to open an edit window and enter the number 1 click on OK. Exit window - top right x

Some people found that they could use security.tls.version.min set to 3, BUT to make sending of emails work they had to change this setting: security.tls.version.enable-deprecated, set value to 'True'.

Finally, Restart Thunderbird.

Helpful?

more options

Toad-Hall, Firefox automatically updates so I now have 81.0 and I just manually updated T-Bird version from 68 to 78.3.1 I am now waiting for a response from my server to see if they support tlsv1.2 and will respond to you when I receive an answer.

Helpful?

more options

The first tech I spoke with a few days ago did not make any changes in my Account Settings--Port numbers SMTP and IMAP. He confirmed they were ok. But when I spoke with a different tech today, he had me change the Port to different numbers and also change my Security Protocol to None. And my problem was solved. I am once again able to receive and send email with T-Bird. Thank you for volunteering your time to answer me.

Helpful?

more options

lesley:

re:The first tech I spoke with a few days ago did not make any changes in my Account Settings--Port numbers SMTP and IMAP. He confirmed they were ok. They are OK providing you change the preference setting I mentioned in the first comment - 'Chosen Solution'. This resets the minimum that Thundrbird allows. Yes, you would need to restart Thunderbird after changing the preference in order to force it to work in current session.

re :But when I spoke with a different tech today, he had me change the Port to different numbers and also change my Security Protocol to None. The technician has completely removed security. I could have told you to do that but as it was unecessary I did not. Do you really want to use that setting ?

If you use the original server settings and reset the preference I mentioned in Chosen Solution then at least you would have some security albeit not the most up to date.

Helpful?

more options

I did question the tech about changing Security Protocol to None and he assured me there was no problem, but I prefer to go with your advice and solution and will make the necessary changes....although as you mention the security will not be the most up to date. Better some than none. Thank you again.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.