Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

For the last week or so(09/1?/2020-now) I cannot access evga.com using Firefox

  • 5 replies
  • 1 has this problem
  • 38 views
  • Last reply by FredMcD

more options

Firefox is up to date, cache and all temporary files have been deleted, system has been restarted multiple times, have tried disabling ad-blockers and all security...

ALL other sites are working perfectly. but when trying to access evga.com or any EVGA pages I get a blank white page with no errors, just plain white.

if I use Internet Explorer, Edge, or Chrome the site shows and works fine.

what could be causing this issue?

example attached

Attached screenshots

Chosen solution

Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

Read this answer in context 👍 1

All Replies (5)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

safe mode does not help. have tried both safe mode(Restart With Add-ons Disabled > Safe Mode) and disabling all add-ons manually.

doesn't change the inability to access these particular sites.

Helpful?

more options

Chosen Solution

Remove History For One Site {web link}

Open the History Manager <Control> (Mac=<Command>) <Shift> H. In the search bar, enter the name of the site. Right-click on one of the listings and select Forget About This Site. This should remove all information, including any site settings

Helpful?

more options

choosing the drop down menu option "Forget About This Site" from the History panel appears to have done it.

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.