Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Locking Up

  • 3 replies
  • 1 has this problem
  • Last reply by FredMcD

more options

Firefox 80.0.1 is continuously freezing up. No error messages. Sometimes it works again after 30 seconds, and sometimes I have to kill it with task mgr and restart. The issue is not exclusive to any one site.

The issues seemed to have started with the latest release.

The only add on I am running is LastPass for Firefox.

I have tried several things found in troubleshooting guide on here, to no avail.I have even uninstalled and clean installed firefox and run with and without lastpass installed with the same results.

As much as I hate Google Chrome, I am forced to use it as default.

Please help.

All Replies (3)

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

MemTest LAST UPDATED : 12/04/2020 Could you please run a tool from in order to check the integrity of your RAM?

You will need a thumb or disk drive to install it on.

Do you let Windows handle the page file or did you set a fixed size ? If you use a fixed size for the page file then try the former and let Windows handle the page file.


more options

RAM is not the issue. The PC is loaded.

Today, it will not run long before firefox locks up hard, and Im forced to use task mgr to close.

I did run it in safe mode, and it seems to do fine. I surfed for over an hour trying to see, and it appears fine in safe mode.

I also disabled all the plug-ins, and laspass ( the only extension i have installed) but the problem persists.

I didnt have this issue before the latest version.

Thanks in advance


more options

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.