Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

enabled add-ons crash google maps

  • 16 replies
  • 1 has this problem
  • 14 views
  • Last reply by FredMcD

more options

use google maps with add-ons enabled

All Replies (16)

more options

Excellent.

Helpful?

more options

When add-ons are enabled, google maps crashes...

Helpful?

more options

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 Submitted crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx57

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Helpful?

more options

Respected Friend,

When I try to open google maps from toolbar with add-ons enabled. While my locale is right most of the time, the screen freezes (crashes?) and I get the following notification regarding the tab: https://www.google.com/maps/@41.6043265,-81.5394721,17z Nothing seems to have helped now for 5 days. Thanks for any help offered

Helpful?

more options

Hi jkelley611, the way your question is phrased, it leads me to think:

(1) When you test Google Maps normally, either the tab stops loading/becomes unresponsive, or you get an error message in the tab like "Gah, the tab crashed". Can you clarify which one?

(2) When you test in Firefox's Safe Mode by using Help > Restart with Add-ons Disabled, then it works normally. Is that correct?

I get the following notification regarding the tab: https://www.google.com/maps/@41.6043265,-81.5394721,17z

Where do you get the notification?

Modified by jscher2000

Helpful?

more options

Yes, that's exactly the problem. Any ideas?

Helpful?

more options

Firefox's Safe Mode disables all extensions, but also blocks Firefox from using hardware acceleration.

Could you try disabling Firefox from using hardware acceleration? This is a potential workaround for incompatibilities between Firefox and your graphics card/chipset driver software. This article describes where to make that change: Firefox's performance settings. This will take effect the next time you exit Firefox and start it up again. Any difference?

Since hardware acceleration improves the appearance of fonts and animations, you may want to check whether graphics card/chipset driver updates are available for your system. This article suggests safe ways to do that: Upgrade your graphics drivers to use hardware acceleration and WebGL.

Helpful?

more options

The performance setting reset did not solve the problem. The mac book pro is running High Sierra: 10.13.6. Not sure if it didn't start after I updated to 80.0.1. I can use google maps with the Brave browser.

Helpful?

more options

So most likely there is a conflict with one of your extensions. It seems you have (at least) 5 ad blockers running simultaneously. Could you try only running one at a time by disabling the others on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

To disable an extension, click its blue slider switch. After a moment, it will move from the Enabled list to the Disabled list.

Any difference?

Helpful?

more options

Used slider to disable all ad blockers and it still crashes.

Helpful?

more options

Closed all extensions with slider and google maps still crashes.

Helpful?

more options

Used Help to restart with all add-ons disabled and google maps worked.

Helpful?

more options

I can't think of what else it might be.

Helpful?

more options

jkelley611 said

Closed all extensions with slider and google maps still crashes.

jkelley611 said

Used Help to restart with all add-ons disabled and google maps worked.


Did you turn off hardware acceleration as jscher2000 suggested?

Helpful?

more options

jscher2000 thanks for your time.

FredMcD, yes. Still crashes.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.