Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

PDFs are always downloaded and local copy opened instead of in-browser

  • 1 reply
  • 1 has this problem
  • 6 views
  • Last reply by jscher2000

more options

Hello, at some point in the recent updates (with FF 80? I can't say as I have skipped a few updates over summer and only recently updated again to the most recent Beta), the way in which my Firefox browser handles PDFs has changed. After quite a bit of research and scouring through other threads I haven't been able to find a way to reverse it. I do hope there is...

-PREVIOUS BEHAVIOUR- 1) When I clicked on a link to randomsite.com/example.pdf, FF would open the PDF within the browser, either in the same tab or (if I requested it) in a new tab or window. The URL line would show "randomsite.com/example.pdf 2) The only exception was where a website had forced the PDF to be downloaded, in which case the dialogue asking me how I wanted to open the file would appear. In earlier days, in that case I had to pick Adobe or Preview or similar, more recently the dialogue also allowed me to open the file in Firefox. In that case, the URL line would show the local URL, i.e. "file:///Users/Michael/Downloads/example.pdf"

-CURRENT BEHAVIOUR- 1) What now happens is for any PDF I click on whatsoever, Firefox forces me to download it. Depending on what I put in about:preferences, I either get the dialog window asking me to make a choice, or it directly opens a new Firefox tab, but crucially it still downloads the file and shows me the local URL of it.

-WHAT I WOULD LIKE- A way to revert to the previous behavior where for 90% of PDFs, I never downloaded them but just viewed them in-browser. I look at a large number of different PDF files online every day for my work and I certainly don't want to download all of them and having to de-clutter my download folder all the time.

-WHAT I HAVE TRIED- - I went to "Applications" in about:preferences. I can set the relevant entries for PDF files to "Always ask" or to "Open in Firefox" but even with the latter set, it still downloads them and opens the local copy, rather than not saving a local copy in /Downloads/ at all. - I have checked in about:config and "pdfjs.disabled" is set to "false" as it should be

I don't think I have any extensions or add-ons related to PDFs, in any case I haven't installed any new ones recently.

Any clues appreciated, my overflowing Downloads folder is grateful.

All Replies (1)

more options

mbimmler said

-WHAT I HAVE TRIED- - I went to "Applications" in about:preferences. I can set the relevant entries for PDF files to "Always ask" or to "Open in Firefox" but even with the latter set, it still downloads them and opens the local copy, rather than not saving a local copy in /Downloads/ at all. - I have checked in about:config and "pdfjs.disabled" is set to "false" as it should be

The top choice on the Preferences page ("Open in Firefox") should work the same as previous versions when sites serve a PDF as:

  • Content-Type: application/pdf
  • Content-Disposition: inline (or unspecified)

The PDF should be stored in the web cache like an HTML page or inline image instead of being treated like a download.

I can't think of a setting to change that. Hopefully another support volunteer can think of what might be causing it.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.