Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

on screen keyboard does not work on firefox. It works on Edge and Chrome

  • 18 replies
  • 1 has this problem
  • 32 views
  • Last reply by jscher2000

more options

on screen keyboard does not work on firefox. It works on Edge and Chrome

All Replies (18)

more options

Enter about:config in the URL bar and check the following preferences:

  • ui.osk.enabled
  • ui.osk.debug.keyboardDisplayReason

Helpful?

more options

Thank you for your suggestion. This did not work. I am on the latest upgrade of Win 10. not sure if that is the issue

Helpful?

more options

larbrg said

TyDraniu said

Enter about:config in the URL bar and check the following preferences:
  • ui.osk.enabled
  • ui.osk.debug.keyboardDisplayReason
Thank you for your suggestion. This did not work. I am on the latest upgrade of Win 10. not sure if that is the issue

I think that was a question, not a suggestion.

ui.osk.enabled probably has its default value of true. What is the value of ui.osk.debug.keyboardDisplayReason, or is it blank?

Does it make any difference if you double-click ui.osk.detect_physical_keyboard to switch it to false?

Helpful?

more options

everything look correctly set except

ui.osk.on_screen_keyboard_path this is blank

Helpful?

more options

What kind of tablet is it?

Helpful?

more options

Surface 7

Helpful?

more options

ui.osk.debug.keyboardDisplayReason says this IKPOS: Keyboard presence confirmed.

ui.osk.on_screen_keyboard_path is blank

Helpful?

more options

larbrg said

ui.osk.debug.keyboardDisplayReason says this IKPOS: Keyboard presence confirmed.

If you clear out that value, make sure ui.osk.detect_physical_keyboard is set to false, and restart Firefox, does it stop using a physical keyboard as a reason not to display the on-screen keyboard?

Helpful?

more options

Still not working. Onscreen keyboard tries to pop up and immediately shuts down. Physical keyboard works. When I take it off and let the Surface become a tablet the on screen keyboard tries to pop up and then it shuts down.

Helpful?

more options

larbrg said

Still not working. Onscreen keyboard tries to pop up and immediately shuts down. Physical keyboard works. When I take it off and let the Surface become a tablet the on screen keyboard tries to pop up and then it shuts down.

Okay, this is a good clarification. Originally the issue sounded like Firefox wasn't detecting that your physical keyboard was removed.

That said, I don't know why, if the cursor is still in a field that accepts input, the OSK would disappear. Does it matter what type of field you tap in? For example, this forum uses a very basic textarea control for input. Email sites generally use a heavily scripted rich text editor.

Helpful?

more options

If i put my curser in the search bar on firefox the osk pops up for a second and goes away. I can try an manually bring up the osk it does the same thing pops up and goes away. It is almost like a pop up blocker is causing this

Helpful?

more options

When you tap in the address bar, is the Top Sites drop-down list opening immediately, or do you have that disabled on the Options page*? Just wondering if there is dualing popups problem.

* Privacy & Security > Address bar section > [ ] Top Sites

Helpful?

more options

I can see my top sites immediately

Helpful?

more options

larbrg said

I can see my top sites immediately

Any difference if you turn that off on the Options page?

Helpful?

more options

there was a firefox update done to my computer on Sept 6th. Wonder if this is the issue. I never had this problem until recently. How do you get a hold of somebody at firefox/ mozilla

Helpful?

more options

Firefox 80.0 and 80.0.1 released recently, and you might have installed one of those versions on September 6th.

I'm not sure who you want to get a hold of at Mozilla. There isn't phone/email support. You can file a new bug report so it's logged as an issue for a future update.

Preparatory to filing a bug, can you confirm that the problem occurs in this test:

Could you try:

New Profile Test

This takes about 3 minutes, plus the time to test the issue.

Inside Firefox, type or paste about:profiles in the address bar and press Enter/Return to load it.

Take a quick glance at the page and make a mental note of which Profile has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

Click the "Create a New Profile" button, then click Next. Assign a name like Sept2020, ignore the option to relocate the profile folder, and click the Finish button.

Firefox will switch your default profile to the new one, so click the Set as Default Profile button for your regular one to avoid an unwanted surprise at your next startup.

Scroll down to Sept2020 and click its Launch profile in new browser button.

Firefox should open a new window that looks like a brand new, uncustomized installation. (Your existing Firefox window(s) should not be affected.) Please ignore any tabs enticing you to connect to a Sync account or to activate extensions found on your system so we can get a clean test.

Does the on-screen keyboard work any better in the new profile?

When you are done with the experiment, you can close the extra window without affecting your regular Firefox profile. (Sept2020 will remain available for future testing.)

Helpful?

more options

osk stil does not work with the other profile. the ui.osk.on_screen_keyboard_path is blank should there be a path?

Helpful?

more options

I don't know whether there should be a path; I don't have a tablet to check on.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.