Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why the same browser version is displaying the fontawesome icons differently on different devices???

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by cor-el

more options

Hi,

I'm the owner of the website www.joyce-mag.com and I have an issue with icons not appearing in the menu (arrows + social media icons) on my device (2019 MacBook Pro with the latest version of Firefox), but appearing on other devices.

So why the same browser version is displaying the fontawesome icons differently on different devices??? I feel like I have an issue to fix but the developer of the theme and my own developer who is also my host provider both can't find any issue.

Thank you, Lauren

Hi, I'm the owner of the website www.joyce-mag.com and I have an issue with icons not appearing in the menu (arrows + social media icons) on my device (2019 MacBook Pro with the latest version of Firefox), but appearing on other devices. So why the same browser version is displaying the fontawesome icons differently on different devices??? I feel like I have an issue to fix but the developer of the theme and my own developer who is also my host provider both can't find any issue. Thank you, Lauren
Attached screenshots

All Replies (3)

more options

You can check gfx.downloadable_fonts.enabled on the about:config page and make sure it is set to true (if necessary double-click the line to toggle its value to true).

Also make sure you allow pages to choose their own fonts.

  • Options/Preferences -> General: Fonts & Colors -> Advanced
    [X] "Allow pages to choose their own fonts, instead of my selections above"
more options

Hi,

Thank you for this but unfortunately, it doesn't solve my problem. Is it a coding issue? I don't have this problem with Chrome or Safari.

Thank you

more options

You are definitely blocking this font from loading if you see little boxes with the hex code.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.


You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window