Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browser search finds German Websites

  • 2 replies
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

When I do a search in Firefox, about half of the choices are in German. I only want English results. I think my browser thinks I'm in Europe. How do I change this?

When I do a search in Firefox, about half of the choices are in German. I only want English results. I think my browser thinks I'm in Europe. How do I change this?

All Replies (2)

more options

What do these websites say about your location?

http://whatismyipaddress.com/ Under the map, look for Location Not Accurate?

http://browserleaks.com/geo

https://whatismyipaddress.com/geolocation

https://html5demos.com/geo/

https://www.iplocation.net/find-ip-address

How to set your location manually in Firefox(Windows) https://support.mozilla.org/en-US/questions/1197142#answer-1115502

more options

Are you possibly using a VPN or proxy that locates you in another country (region) ?

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window