Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default search engine keeps changing to Yandex withouth my consent after firefox updated

  • 6 replies
  • 1 has this problem
  • 12 views
  • Last reply by Standard8

more options

Mozilla has an agreement with Yandex in my region. I understand the need for a sponsor, but I am very unhappy with my preferred search engine being changed to Yandex after each Firefox update without my consent or knowledge.

All Replies (6)

more options

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Yandex “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Helpful?

more options

I don't have any of those extensions installed. Neither have I those applications installed. Also this problem is cross-platform ( I interchange an Ubuntu 18.04, Windows 10, and a MacOs 10.15.6 throughout my work day)

Helpful?

more options

Helpful?

more options

Hi, can you look at something for me please?

If you go to the menu button New Fx Menu , then click Add-ons.

On the page that appears, is there a languages section?

Helpful?

more options

I do not see a "languages" section at the add-ons page (same as about:addons?) My language settings are under about:preferences#general and is set to English (USA), although I live in a different geographical region.

Helpful?

more options

baris.malcioglu said

I do not see a "languages" section at the add-ons page (same as about:addons?)

Yes, that's the same.

My language settings are under about:preferences#general and is set to English (USA), although I live in a different geographical region.

Ok, I'm not really sure what this can be. We have just made some significant changes in 79 to the search service back-end which might help. Can we wait until 80 comes out (somewhere around 25th Aug) and see if this affects you then?

If it does, then we can look at it in greater detail.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.