On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How Do I turn off Firefox Save-Password Question

  • 2 replies
  • 1 has this problem
  • 38 views
  • Last reply by cor-el

more options

Although Ask to save logins and passwords for websites is unchecked, I am asked if I want them saved at every site that requires a password. How can I change this? Windows 10, on MSI laptop.

Although ''Ask to save logins and passwords for websites'' is unchecked, I am asked if I want them saved at every site that requires a password. How can I change this? Windows 10, on MSI laptop.

All Replies (2)

more options

hi bro,its quite simple just follow these steps, 1. Click the Firefox menu in the toolbar i.e., a three horizontal lines symbol at top right corner. 2.Now choose preferences in the menu 3.Now click on privacy&security option 4.Now by scrolling down you find a segment named "Logins and passwords" 5.Now untick the “Ask to save logins and passwords for websites”.(or) if you want to do this only for particular sites you can click on exceptions options wihout unticking and there you can give the site adress where yo don't want mozilla to ask save password

need any more help I'm there :)

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window