Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to get a black screen, instead of a white, when opening a new window?

  • 5 replies
  • 1 has this problem
  • Last reply by jscher2000

more options

I'd like to help you all at Mozilla in the evenings. I have just one issue with that. I have installed Linux Mint Cinnamon and made my theme dark and downloaded the add-on "Dark Background and Light Text". It is almost 100% wonderful. Redshift is activated too, in order to avoid the blue light, so that I will keep the rhythm of my sleep. I love it.

However. Every time I start a new window in Firefox or click the "+" my whole screen turns WHITE!!! This is VERY annoying. I want it to be dark, of course. This is also an issue if I am going to help you out at Mozilla in the evenings. Dark Background and Light Text does not work in your own forum. Why not integrate this add-on into Firefox?

In my opinion this is a very high priority issue, not only for this reason, but considering that we will all would save energy, batteries and the environment when using AMOLED technology together with Firefox, especially if it is very easy for the users to discover and to activate.

Attached screenshots

All Replies (5)

more options

Before Firefox starts loading content into a tab and styling it, there is an empty frame. I think this empty frame always has a white background, but possibly it is different with a dark system theme.

You could try setting a preference in Firefox to see whether this helps. It works for Mac users, but I don't know about other systems:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box, type or paste ui.systemUsesDarkTheme

(3) Firefox should display a bar with some radio buttons to choose a new preference type, followed by a + button. Choose Number and click the + button:

(4) Edit the value to 1 and then click the blue check mark button or press Enter/Return to save the change.

For reference, this value is used to answer websites' inquiries about your preferred color scheme. Setting it manually overrides Firefox answering the inquiry based on your system theme:

  • 0 => Light
  • 1 => Dark
  • 2 => No Preference

Does that have any effect on your Firefox? When I test on Windows, there's no white flash for new tabs, but there is a brief flash for a new window.

Another possible approach is to create optional userChrome.css and/or userContent.css files to apply custom styling to the empty window. I'll link to a thread on that over on Reddit:


more options

Sure. Could be an empty frame. I see this as a programmers challenge at Mozilla.

No. It is not different with a dark system theme. Changing ui.systemUsesDarkTheme has no effect on the white frame.

Changing ui.systemUsesDarkTheme also has no effect on this annoyingly white Mozilla support screen.


more options

There isn't a built-in setting to modify the colors of web pages. You could look at


more options

I am not looking for that. No add-ons seems to solve this problem, also not the "Dark Reader" add-on. It seems to be a programming issue for Mozillas programmers. How to contact them I do not know.


more options

I just remembered that extensions are not allowed to modify this site, so naturally Dark Reader has no effect here. You can file a new issue for dark theme support on the Github for this site's software:

If you need a personal workaround, maybe ShadowFox would work better since it uses userChrome.css/userContent.css and doesn't have the same restrictions as extensions:


Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.