Scheduled maintenance: Thursday, September 24, between 11:30am and 13:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @FirefoxSupport on Twitter

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

setting default browser

  • No replies
  • 1 has this problem
  • 2 views
more options

When I go to settings, web browser it does not list Firefox as an option. I go to the store and click on it and it takes forever to bring it up. I want Firefox browser as my default. thanks.

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.