Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox browser in two languages

  • 1 reply
  • 1 has this problem
  • 12 views
  • Last reply by Metapala

more options

Hello! It seems my Firefox browser is in two languages and I can't change it. I want it to be all in English but it also incorporates my country's language and I don't know how to fix it. Any idea how to fix it and for it all to be in English? I added some screenshots if it'll help.

Chosen solution

somewhat fixed it, downloaded and reinstalled the US version of Mozilla

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

somewhat fixed it, downloaded and reinstalled the US version of Mozilla

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.