Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I start firefox there is always a second page that opens (to install google translate)

  • 9 replies
  • 1 has this problem
  • 16 views
  • Last reply by jscher2000

more options

and I have already changed the starting page and indicated that for an extra page I want an empty page, but it keeps giving that page. This is since the last uodate. I don't want that because it is very enervating !

All Replies (9)

more options

Hi freddy.vermeiren, what is the address of the unwanted page? Is it on a website or is it an internal page starting with:

  • about: or chrome: or resource:
  • moz-extension:

or is the address bar blank?

Does it appear if you set your home page to either "Firefox Home" or "Blank page", or only with "Custom URLs"?

Helpful?

more options

http://www.translatorforfirefox.com/p/whats-new.html

and I did uncheck "What's new" in options.

Doesn't help

Helpful?

more options

http://www.translatorforfirefox.com/p/whats-new.html


and I did uncheck "What's new" in options.

Doesn't help

Helpful?

more options

You can check that these pages aren't set as multiple homepages.

You can check the homepage setting.

Firefox supports multiple homepages separated by '|' (pipe) symbols.

Helpful?

more options

Nothing helps. I updated firefox om my second laptop an oeps.. There the same problem. It must have to be caused by the update. If I can't get a solution I stop using firefox

Helpful?

more options

A what's new page usually indicates that the extension is installed or updated, so this extension should show as installed on the about:addons page and listed on the about:support page.

Helpful?

more options

This extension that is related to the page you're getting -- it should only open that page after installation or extension update:

https://addons.mozilla.org/firefox/addon/google-translator-for-firefox/

Have you tried disabling it on the Add-ons page to see whether that helps? Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading and look for it in the list that follows.

If you need an alternative, this one is in Mozilla's "Recommended Extensions" program:

https://addons.mozilla.org/firefox/addon/to-google-translate/

Helpful?

more options

I deleted the add-on of google translator. Problem solved. But now I dodn't have a translator for my pages anymore

Helpful?

more options

freddy.vermeiren said

I deleted the add-on of google translator. Problem solved. But now I dodn't have a translator for my pages anymore

That's why I suggested another one in my earlier reply. ;-)

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.