Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook page shop not opening with firefox?

  • 6 replies
  • 5 have this problem
  • Last reply by guranedo

more options

My sister have a facebook page with shop that I help her manage, but for some reason lately we can't access the "shop" tab of the page with firefox.

We are getting The page isn’t redirecting properly error. I cleaned cookies and cache, even tried a new private window, nothing. I tried opening in edge and everything worked like no problem.

The page is the following.

We experienced problems both in my workstation and my sister's laptop that also use firefox (latest version, windows 10 up to date).

Any idea? Should I fill a bug or something?

All Replies (6)

more options

I can confirm this, with or without tracking protection or 3rd party cookies. In Chromium/Edge the page work with or without 3rd party cookies – so I believe this is not caused by the browser, but the server side. I'd ask Facebook Support about the issue.

Modified by Balázs Meskó

more options

I am experiencing the similar issue.

Couple of days ago, Facebook Page Shop was working fine with Mozilla Firefox browser. However for some reason, I deactivated the shop and again reactivated it. Post reactivation, the FB Shop stop opening in Firefox. The error I am getting is below with a Try Again button.

The page isn’t redirecting properly An error occurred during a connection to This problem can sometimes be caused by disabling or refusing to accept cookies.

I tried several times with restarting the pc and also clearing history, cache, cookies as well as uninstalling Firefox and then reinstalling it but failed.

Interestingly, I am not having any issue using FB Shop with other browsers.

Any help would be appreciated!

more options

Same problem, I tried all the info that I could find no the net and nope doesnt work but it works fine on MS Edge so its not a facebook problem its firefox, have this since the last update please correct or send info to correct it thanks

more options

I have had this same problem occurring for over two weeks....very frustrating as a business owner. There are no issues with my facebook shop when using any other browers.....just firefox. I hope a fix is offered SOON, as it pains me to switch to another (functional) browser and asking my clients to do the same. Any help would be appreciated! Thank you.

more options

I have the exact same problem but 99% on Ebay, for one I'm unable to browse categories but search and viewing items in the search results works. It's been like this for over a year now, started out showing up quite sporadic and now it won't work at all.

Tried Clearing cache and cookies, disabling more or less everything and finally reinstalling both firefox and windows. Still the same problem persists, works great in any other browser though.

This is getting very frustrating, if there is no solution to this soon I'm gonna have to look at changing browsers permanently rather than switching to another browser when needed :(

more options

Hi guranedo, I think the eBay issue is different. Please start a new question:

Skip over suggested articles and old threads while working through the new question form.

Meanwhile, two additional troubleshooting steps beyond clearing cache and cookies:

First, setting Enhanced Tracking Protection to Strict causes some users to have severe issues with eBay and they need to make an exception (while viewing a broken page, click the purplish shield icon at the left end of the address bar and click the slider switch on the drop-down to turn off ETP on eBay).

Second, you may want to test in Firefox's Safe Mode. In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?