Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

image preview in google searches

  • 6 replies
  • 2 have this problem
  • 70 views
  • Last reply by amdbanan

more options

Ok, how can I remove this "feature" in google searches? See picture 1 and 2. It is extremely annoying.

Attached screenshots

Chosen solution

I'm not a fan of this feature either. Unfortunately, there's not a whole lot that you can do about it with Firefox because it's a change that Google made to their website.

All you can do at the moment is send them feedback to let them know that you dislike the feature. This can be done by pressing the Settings button in the bottom-right of the screen and selecting Send Feedback.

Alternatively, you can also explore other search engines. For example, Duck Duck Go is becoming increasingly popular, especially among users that value their privacy.

Hope this helps.

Read this answer in context 👍 1

All Replies (6)

more options

Chosen Solution

I'm not a fan of this feature either. Unfortunately, there's not a whole lot that you can do about it with Firefox because it's a change that Google made to their website.

All you can do at the moment is send them feedback to let them know that you dislike the feature. This can be done by pressing the Settings button in the bottom-right of the screen and selecting Send Feedback.

Alternatively, you can also explore other search engines. For example, Duck Duck Go is becoming increasingly popular, especially among users that value their privacy.

Hope this helps.

Helpful?

more options

Thx for info. I'm gonna send them feedback.

Helpful?

more options

You can add code to the userContent.css file. Download and save the image to the chrome folder where userContent.css is located.


@-moz-document domain(google.com){
 /*remove preview image*/
 .sbic.sbei{
  /*www.google.com/images/searchbox/desktop_searchbox_sprites302_hr.webp*/
  background: url(desktop_searchbox_sprites302_hr.webp) no-repeat 0 0 !important;
  background-size: 20px !important;
  min-height: 20px !important;
  min-width: 20px !important;
  height: 20px !important;
  width: 20px !important;
  margin: 0 14px 0 0 !important;
 }
}

See:

Helpful?

more options

cor-el said

THX for the answer, but it won't helps. It seems the code does not work. Mozilla correctly load the UserChrome.css - I tried "Move the Tab Bar Below the Other Toolbars (like Firefox 1.0-3.6)" and everything is fine.

Helpful?

more options

This code needs to be in userContent.css and not in userChrome.css.
The latter is for code to modify the user interface and the former for code to modify web pages like in your case.

Helpful?

more options

Yeah, it works now :D You are my personal hero today. THX.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.