Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF won't open some major websites, so I'm switching to Chrome

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by Scribe

more options

I can't get at my account, or even the site itself, in eBay. I fill in my details (name and PW), press next, and I get a "captcha loading" note at the top of the page (see attached), and that's the end of it. That screen will stay up for weeks if I let it. No captcha, no destination website ever appears. Nor can I get to my bank website. I was willing to simply use a different browser for that, and stick to FF, but why bother? I'm tired of fighting with Firefox.

Attached screenshots

Chosen solution

Hi, try turning off 'Enhanced Tracking Protection' in Firefox by clicking the shield icon at the left-hand end of the address bar when you are on the site - Enhanced Tracking Protection in Firefox for desktop

If that doesn't help, disable any ad blocker you may be using then reload the site.

Try deleting ALL references to eBay (if this works, you might need to do it for your banking site as well). To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for eBay by typing it into the Search History field in the top-right corner. Now in the search results, right-click on eBay, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a few minutes to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.


Hold down the Option key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Read this answer in context 👍 0

All Replies (2)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).
Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

Helpful?

more options

Chosen Solution

Hi, try turning off 'Enhanced Tracking Protection' in Firefox by clicking the shield icon at the left-hand end of the address bar when you are on the site - Enhanced Tracking Protection in Firefox for desktop

If that doesn't help, disable any ad blocker you may be using then reload the site.

Try deleting ALL references to eBay (if this works, you might need to do it for your banking site as well). To do that, open the 3-bar menu > Library > History, then click the Show All History link at the bottom of the list to open the History-library window. Search for eBay by typing it into the Search History field in the top-right corner. Now in the search results, right-click on eBay, and select Forget About This Site. (Browsing and download history, cookies, cache, active logins, passwords, saved form data, exceptions for cookies, images and pop-ups for that site will be removed). Give it a few minutes to complete the deletion, then try the site (not from an old bookmark) again. More - Delete browsing, search and download history on Firefox.


Hold down the Option key when you start Firefox to start in Safe Mode. More - Troubleshoot Firefox issues using Safe Mode.

If it works in Safe Mode, disable any theme or extensions you have - 3-bar menu > Add-ons > Themes/Extensions, then restart Firefox; now if it's still OK, re-enable them one by one until you find the culprit. You may need to restart Firefox after enabling some extensions.

If your question is resolved by this or another answer, please help other users by marking the best reply as Solved. Thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.