Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am using the latest firefox (recently updated) on windows 7

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by FredMcD

more options

When I try to login into www.myverizon.com, after entering user Id and password, the sign in button does NOT activate. It remains "grayed out" and inactive. Neither clicking on the buton, nor pressing the "Enter" key will send the ID and password for verification or denial. However it works fine on another browser. Please advise.

Thank you, Ovide Rajotte

edit: removed personal information for your protection. please note that we cannot offer support via telephone, so please continue in the forum. thanks for your understanding! (philipp)

Modified by philipp

All Replies (1)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link}
by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh).
Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.