Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HELP!!! Firefox is has overridden ALL of my pdf files.

  • 5 replies
  • 1 has this problem
  • 119 views
  • Last reply by jmcohen

more options

HELP!!! The thousands of pdf files on my computer and two external hard drives are now Firefox html files. I did NOT do anything do cause this problem. Also, when I try to save MS Word files as pdf files, they are saved as Firefox html files. Yes, I've double-checked the options setting and it says pdf files. HOW CAN I FIX THIS???

Chosen solution

Hello Arman and cor-el, Thank you for your responses, but they didn't help because they didn't address what I wrote. 1. This change (which I did NOT do) affected several thousand pdf files on my computer and 2 external hard drives. There was an automatic change from pdf to Firefox html files with pdf file extensions. 2. This computer is not running on Windows 10. 3. Something happened the last time that Firefox updated. It changed the "default documents" for pdf files on my computer. I was able to override what Firefox changed. Now, all of the thousands of pdf files ARE pdf file.

Read this answer in context 👍 0

All Replies (5)

more options

hello jmcohen..

It should be noted that currently there is no built-in feature that can save webpage as PDF in Firefox. Thus you may not be able to save pages as PDF if you are using an earlier Windows version other than Windows 10.

Run Firefox browser on your Windows 10 PC. Visit the website in Firefox. Click to open the File menu at the top left corner of the Firefox browser window. (Can’t see the menu bar in Firefox? right-click in a blank area at the top of your browser window, a drop-down menu will be displayed. Left-click to select and show menu bar)You will see a drop-down menu.

  • Choose Print Preview, then the print preview page opens.
  • Click Print in the dialog window, then the Printer settings in Windows 10 will pop up.

tell me its help

GREETING FROM: arman

Helpful?

more options

It is possible that you have set Firefox as the default application to handle PDF files in Windows when downloading a PDF file.
Firefox 78+ releases offers a choice to open PDF files that would normally be saved or opened in an external application in Firefox.
See "What's New" in the "3-bar" Firefox menu button drop-down list.

You can disable this new feature by setting this pref to false on the about:config page.

Helpful?

more options

Chosen Solution

Hello Arman and cor-el, Thank you for your responses, but they didn't help because they didn't address what I wrote. 1. This change (which I did NOT do) affected several thousand pdf files on my computer and 2 external hard drives. There was an automatic change from pdf to Firefox html files with pdf file extensions. 2. This computer is not running on Windows 10. 3. Something happened the last time that Firefox updated. It changed the "default documents" for pdf files on my computer. I was able to override what Firefox changed. Now, all of the thousands of pdf files ARE pdf file.

Helpful?

more options

Try to open a PDF file in Windows Explorer and select your preferred PDF viewer (you may have to press the Shift key if you click Open in the right-click context menu if Open with isn't available). If you tick the box to use that application always then this should be sufficient to recover from this change.

Helpful?

more options

cor-el, please read my response above. I had to go to Start-> Default Programs. I was able to "fix" the problem there. My question remains: WHY did this occur? It seems to have been a result of Firefox's last update. Thank you.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.