Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Seach system renamed

  • 10 replies
  • 2 have this problem
  • 12 views
  • Last reply by cor-el

more options

Hello,

How to fix renamed "Yandex"?

Attached screenshots

All Replies (10)

more options

Hi Leon20897, I'm not sure what you mean about the Yandex search engine being renamed. I wonder if it is a problem with the font used to show that list?

Helpful?

more options

Hello Leon20897,

Is the name   "Yandex"  displayed as question marks in diamonds
anywhere else, or just under One-Click Search Engines ?

Helpful?

more options

You see diamonds with a '?' when you view content with an eight bit Western or Windows encoding and not as Unicode.
In your case you see the diamonds and not the actual Cyrillic glyphs (Яндекс).
You can check if you can change the Text Encoding to Unicode (View -> Text Encoding).

Helpful?

more options

How was Yandex previously displayed (Latin or Cyrillic) ?

Are you using Firefox 78.0.1 as this version has a fix for search engine issues ?

You can rename/remove search.json.mozlz4 (and possible search.json, search-metadata.json, search.sqlite) in the Firefox profile folder with Firefox closed to rebuild the search engines registry.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Firefox will rebuild the search.json.mozlz4 file from the builtin search engines.

Helpful?

more options

Hi, all! Sorry for a long answer.

I use Firefox Browser 78.0.2 x64

There isn't problem with the fonts. Everywhere they work fine - on sites, Firefox tabs, etc.

"You can check if you can change the Text Encoding to Unicode (View -> Text Encoding). " - where to do that?

Helpful?

more options

Leon20897 said

"You can check if you can change the Text Encoding to Unicode (View -> Text Encoding). " - where to do that?

When you press the Alt key on your keyboard, it will bring up the menu bar (upper left); there you can click on "View" => Text Encoding.

Helpful?

more options

McCoy said

Leon20897 said

"You can check if you can change the Text Encoding to Unicode (View -> Text Encoding). " - where to do that?

When you press the Alt key on your keyboard, it will bring up the menu bar (upper left); there you can click on "View" => Text Encoding.

I cant press on "Text Encoding", because it's inactive.

Helpful?

more options

Leon20897 said

I cant press on "Text Encoding", because it's inactive.

You're right;   it's greyed out   -   I hadn't paid any attention to it, but it's greyed out for me too (on this site and any other site)

Then I found these bug reports :

https://bugzilla.mozilla.org/show_bug.cgi?id=1461741

https://bugzilla.mozilla.org/show_bug.cgi?id=1479364

But that still doesn't explain why under One-Click Search Engines, "Yandex" is displayed as question marks in diamonds ......

Have you read   cor-el's   last post ?

Helpful?

more options

Mere stab in the dark, but as Yandex is only displayed as question marks in diamonds under One-Click search engines and nowhere else; what if you remove it, and then add it again, using this link :

https://yandex.com

I added Yandex to my One-Click search engines,   just to see what would happen, but of course there were no question marks in diamonds   (just one big question mark on my face).

Helpful?

more options

You haven't confirmed how Yandex was displayed in the one-click section, but I assume it was displayed a Cyrillic as Latin should work properly.

What Firefox locale (user interface language) do you use and what is your OS locale ?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.