Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Delete Items from Search Bar

  • 5 replies
  • 1 has this problem
  • Last reply by drc0304

more options

I just installed Firefox (64-bit) v 78.0.1.

Here is the problem---> I am trying to delete individual items/urls from the search drop down menu. The usual/previous way to do this was to use the cursor to highlight the item to be deleted and click SHIFT+DELETE.

This does not seem to work. Additionally, when I went to the HELP page to discover how to do this, it indicates using the procedure above--which does not work.


Dennis Celeschi

All Replies (5)

more options

What kind of items are you referring to ?
Do they have a website favicon next to it?

A possible star attached to the favicon means that this is a bookmark.
If there isn't a favicon then you can check in Options/Preferences that kind on content to display, Firefox 78 includes "Top sites" data as possible items.

The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, and search suggestions.
You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Options/Preferences -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    Open tabs
    Top sites
more options

I am talking about the drop-down menu of visited websites/History in the URL bar.

In previous versions of FF, all I had to do was use the cursor to highlight the item in the drop-down menu to be deleted and hit SHIFT+DELETE --- poof, it was gone.

This appears to have changed and DOES NOT WORK.

Your solution is extremely complicated and not what I was looking for.

Version 78.0.1 has been messed up in my estimation and I am rather disgusted.

What used to work DOES NOT WORK any longer.

Why is this so difficult?

more options

This is about history entries with a favicon ?

This still works for me in Firefox 78.0.1 if I use cursor Down to highlight an entry and press Shift+Delete.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

If errors are reported with "Verify Integrity", close and restart Firefox and retry.

more options

Hi Dennis, do you mean the list that drops down automatically before you start typing anything? Starting in Firefox 75, when you click the address bar, a list of your first 8 Top Sites drops down. That list cannot be edited in the drop-down, if you want to remove a Top Site you need to do that through the new tab page (also known as Firefox Home).

What would you like to do with this list?

(A) Clean it up

You can do that on the new tab page. See: Customize items on your Firefox New Tab page for how to unpin, add, dismiss, and rearrange the tiles used for the automatically dropping list.

(B) Get rid of it

Firefox 78 now has a check box for this on the Options page:

more options

This is for cor-el

Here is what I found on your suggestions:

Task: checkIntegrity

+ The places.sqlite database is sane + The favicons.sqlite database is sane

I have NO idea what "sane" means.

Everything was fine until I installed FF V78.0.01

For me, the SHIFT+DELETE simply no longer works and I don't know what to do next.

I have tried deleting Mozilla in Roaming and re-installing and nothing I do seems to fix the problem.

FF has virtually become UNUSEFUL to me now.