Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When I search for firefox in windows search bar my most recent search history shows up there and I dont want this to happen

  • 4 replies
  • 1 has this problem
  • 14 views
  • Last reply by cor-el

more options

how do i stop this form happening

Attached screenshots

Chosen solution

Note that for the jump list you have these prefs on the about:config page.

browser.taskbar.lists.frequent.enabled
browser.taskbar.lists.recent.enabled
browser.taskbar.lists.tasks.enabled

Read this answer in context 👍 0

All Replies (4)

more options

I don't think that is your search history, this looks similar to the suggestions you see on various online search pages like Google that show popular suggestions based on what you type in the search bar.
I don't know if you can disable this feature for the Windows search bar.

Helpful?

more options

Click in the field, enter a character or two and STOP ! Using the arrow keys, highlight an unwanted entry. Then press Shift > Delete Repeat as needed.

Helpful?

more options

Hi dictator, I think that is the same list of Frequent Sites you would see on the "Jump List" displayed when you right-click the Firefox icon on the Taskbar. Firefox has some preferences for the Jump List, but if you hide the Frequent list then the Jump List shows the Recent list, which may be worse. Hmm.

Helpful?

more options

Chosen Solution

Note that for the jump list you have these prefs on the about:config page.

browser.taskbar.lists.frequent.enabled
browser.taskbar.lists.recent.enabled
browser.taskbar.lists.tasks.enabled

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.