Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Flash doesn't work for a specific website.

  • 2 replies
  • 1 has this problem
  • 4 views
  • Last reply by James

more options

https://support.mozilla.org/en-US/kb/flash-blocklists .

If the link above above worked , on my Firefox browser flash is in "extensions" not "plugins". What I saw is not consistent with what was described in the directions for help. That is, about "blocking dangerous sites". I did not see this anywhere.

I loaded the same website in Google Chrome and it worked fine.

elothas.

All Replies (2)

more options

Flash in Firefox is a (NPAPI) Plugin and not an Extension. It is installed on your system and not in Firefox like a Extension is. For example type about:plugins in the Location (address) bar to see where it is installed on your system.

Go the Add-ins Manager about:addons and on the left click on Plugins then click the ellipsis (3-dot) icon next to the Flash entry and select Options/Preferences from the drop-down menu. Remove the checkmark [v] next to Block dangerous and intrusive Flash content.

Modified by James

more options

Since Firefox 69.0 and later the Flash Player Plugin (old name of Shockwave Flash) can only be set to Click to Activate or Never Activate.

If you have something listed in Extensions claiming to be Flash or Flash Player or Flash Update etc then it could be malware as a large number of these fake Flash extensions have been added to Addons blocklist over the years as can be seen at https://blocked.cdn.mozilla.net/