Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

getting blank page on startup instead of homepage

  • 29 replies
  • 2 have this problem
  • 52 views
  • Last reply by Mark R

more options

getting blank page on startup instead of homepage

clicking on home button and ctrl + n brings me to homepage.

can u help me?

77.0.1 (64-bitars)

homepage: https://outlook.live.com/mail/inbox

getting blank page on startup instead of homepage clicking on home button and ctrl + n brings me to homepage. can u help me? 77.0.1 (64-bitars) homepage: https://outlook.live.com/mail/inbox

All Replies (9)

more options

I think that if I hold down Shift-key, while clicking on FireFox, it opens in Safe Mode??

more options

Here is Screen pic of what I get.

more options

Oh.. Should have included this with the screen pic. Got the SAME thing when I Shift-clicked on FireFox and chose Safe-Mode start.

more options

Mark R said

jscher2000 said

Hi Mark, is your experience consistent with what other users reported (especially with Yahoo as their home page):
  • Home page doesn't show at startup, unless cache was cleared during the previous session
  • Home page loads normally when either clicking the Home button on the toolbar or launching a new window (Ctrl+n on Windows, Command+n on Mac)
Been using Cnet.com as Homepage for YEARS. Only had this problem in last week or two. about:config shows correct page. Shows 1 to use that page. Only seems to happen AFTER starting pc, and closing Firefox, then re-opening. Have NEVER used Ctrl+n in Firefox. Did Not need to click on Home button. Was Just THERE when opened Firefox for First time.

Mark, I wasn't asking about whether you ever did those things. I was hoping you would confirm that those actions load your home page normally even when Firefox does not load the URL at startup.

One workaround Yahoo users are using is not to specify the complete URL for the home page. So in this case, instead of

https://www.cnet.com/

you would try

cnet.com

That forces Firefox to go through a redirect cycle which for some reason helps Yahoo users. Maybe it will help you??

more options

When I start my computer, then bring up Firefox, it seems to come up the way it should. Which I mentioned. When I close Firefox, then open it again, I get the blank page. If I start typing in cnet...... the Entire URL address comes up. I select it, and get Cnet.com on my screen. It has NO problem getting to the URL. Firefox has a problem REMEMBERING what is IN the Home Page Options (correctly).. Nothing to do with Yahoo. Is Norton Utilities Premium removing browsing caching, as part of its Junk/Temp cleanup? I will try Changing the HomePage setting of 4 Plus years, to see if it works... Even if it Does, there has been SOMETHING else that has changed to create this problem. I have NOT been changing Firefox settings. Whatever changed (if a change in a Firefox update) should be Fixed.

    • Holding down the Shift key, then clicking on Firefox icon brings up a window where you can choose to open **Firefox in Safe-mode.
more options

Changed Home to cnet.com. Closed Firefox. Opened Firefox.. It Came Up!!! Closed it again. Opened... NOPE.. Same Blank. Typed cnet into Url field. Chose site. Enter.. Got to the site. Options. Home. Use Current Site. Https:/www.cnet.com went back in. Closed Firefox. Opened. Blank. Changed to cnet.com again. Close. Open. Still blank. Try at solution worked ONLY ONCE. NOT using Safe-mode at moment. I think I mentioned that Home Page came up Blank in Safe-mode.

more options

Hi Mark, it sounds like the same problem some users have experienced starting in Firefox 77. I have not seen an explanation of what causes it. It seems to be linked to Firefox's web cache in some way.

Can you think of any action that other software might be taking on your system to clear Firefox's web cache when Windows starts up? That would explain the mixed results.

more options

Norton Utilities Premium.... Released just a few weeks ago... Or, at least, that is when I got the offer... Does Auto cleanup of Windows and browser junk/temp files. Just looked at Utilities settings.. Has cleaning of Browser Cookies and Browser cache files. Maybe, after pc is first signed into, Utilities has Not gotten to cleaning cache yet.. So, Open Firefox, and it works... Then, closing Firefox, then re-open, the cache has been cleaned. ????????????????? Just took off setting to remove Browser Cache files.. Will see what happens..

more options

Just started up my pc. Checked for updates (Norton), opened e-mail (Thunderbird), opened Firefox. Got to Cnet.com on open, as Home Page. Closed Firefox. Opened Firefox. Blank Tab. No Home Page. So, Utilities didn't Get to do Anything yet (auto-clean), I believe. Other Startup programs got to Startup. But, Firefox ONLY uses my SET (for Years) Home page on the FIRST open. Only about TWO minutes between First open of Firefox, close, then open again. If I Re-booted, or Shut-down and tried again, would it be the same? Well, it WAS re-booted New, this morning, and it is the Same. Going to put back the Browser Cache files clean setting on Utilities, since that is probably NOT the problem. What changes were in the last Firefox update? Not too certain that it is Another program getting in the way. Unless that Other program is checking for the status of Firefox; first on?? 2nd on??

  1. 1
  2. 2